{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-3505 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2012-3505 is a medium-severity denial of service vulnerability in n/a, published on 9 Oct 2012. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2012-3505 and fix it if it is affected.\n\nWhat it is: CVE-2012-3505 is a medium-severity denial of service vulnerability in n/a, published on 9 Oct 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2012-3505 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-3505/ (Markdown: https://insights.sbomify.com/CVE-2012-3505/index.md)","id":"CVE-2012-3505","markdown":"https://insights.sbomify.com/CVE-2012-3505/index.md","name":"CVE-2012-3505","record":{"aliases":["DEBIAN-CVE-2012-3505","DSA-2564-1","GHSA-h6wx-vrmp-rrjr","openSUSE-SU-2024:10460-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Tinyproxy web proxy","requires_auth":"none","summary":"Remote attackers can cause denial of service in Tinyproxy via hash collision attacks using numerous headers, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"tinyproxy","vendor":"banu"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-310","name":null}],"description":"Tinyproxy 1.8.3 and earlier allows remote attackers to cause a denial of service (CPU and memory consumption) via (1) a large number of headers or (2) a large number of forged headers that trigger hash collisions predictably.  bucket.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2012-3505","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2012"},"n_packages":1,"n_references":10,"next":{"headline":"Unspecified vulnerability in the Apache Open For Business Project (aka OFBiz) 10.04.x before 10.04.03 has unknown impact and attack vectors.","id":"CVE-2012-3506"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.8.4-1.8"],"introduced":["0"],"last_affected":[],"package":"tinyproxy","purl":"pkg:rpm/opensuse/tinyproxy\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10460-1"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2012-3504"},"products":["n/a"],"published":"2012-10-09","related":[{"cvss_score":6.8,"headline":"Integer overflow in conf.c in Tinyproxy before 1.8.3 might allow remote attackers to bypass intended access restrictions in opportunistic ci","id":"CVE-2011-1843","kev_date_added":null,"published":"2011-05-03"},{"cvss_score":2.6,"headline":"Misconfiguration in n/a","id":"CVE-2011-1499","kev_date_added":null,"published":"2011-04-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service in Tinyproxy via hash collision attacks using numerous headers, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2012-3505/"}