CVE-2012-3527 TYPO3 allows remote authenticated backend users to unserialize arbitrary objects
Authenticated backend users can execute arbitrary PHP code via unsafe deserialization in the TYPO3 help system.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2012-3527?
CVE-2012-3527 is a medium-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 5 Sep 2012. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
view_help.php in the backend help system in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allows remote authenticated backend users to unserialize arbitrary objects and possibly execute arbitrary PHP code via an unspecified parameter, related to a "missing signature (HMAC)."
Weakness: CWE-502
Which versions are affected by CVE-2012-3527?
6 open source packages ship an affected version, including typo3/cms. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms Packagist | From 4.5.0 | 4.5.19 |
typo3/cms Packagist | From 4.5.0 | 4.5.19 |
typo3/cms Packagist | From 4.6.0 | 4.6.12 |
typo3/cms Packagist | From 4.6.0 | 4.6.12 |
typo3/cms Packagist | From 4.7.0 | 4.7.4 |
typo3/cms Packagist | From 4.7.0 | 4.7.4 |
Products include Debian Debian Linux, Typo3 Typo3.
How do I fix CVE-2012-3527?
Upgrade typo3/cms to a fixed version for your release line: 4.5.19, 4.6.12 or 4.7.4.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2012-3527 being exploited?
There is no known exploitation of CVE-2012-3527 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as GHSA-m4hw-r893-xh4g.