# CVE-2012-3527: TYPO3 allows remote authenticated backend users to unserialize arbitrary objects

> Authenticated backend users can execute arbitrary PHP code via unsafe deserialization in the TYPO3 help system.

- **Severity:** Medium 4.6 (`AV:N/AC:H/Au:S/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Sep 2012
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-m4hw-r893-xh4g

## What is CVE-2012-3527?

CVE-2012-3527 is a medium-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 5 Sep 2012. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

view_help.php in the backend help system in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allows remote authenticated backend users to unserialize arbitrary objects and possibly execute arbitrary PHP code via an unspecified parameter, related to a "missing signature (HMAC)."

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2012-3527?

6 open source packages ship an affected version, including typo3/cms. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms` | Packagist | From 4.5.0 | 4.5.19 |
| `typo3/cms` | Packagist | From 4.5.0 | 4.5.19 |
| `typo3/cms` | Packagist | From 4.6.0 | 4.6.12 |
| `typo3/cms` | Packagist | From 4.6.0 | 4.6.12 |
| `typo3/cms` | Packagist | From 4.7.0 | 4.7.4 |
| `typo3/cms` | Packagist | From 4.7.0 | 4.7.4 |

Products: Debian Debian Linux, Typo3 Typo3.

## How do I fix CVE-2012-3527?

Upgrade typo3/cms to a fixed version for your release line: 4.5.19, 4.6.12 or 4.7.4.

## Is CVE-2012-3527 being exploited?

There is no known exploitation of CVE-2012-3527 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-3527 and fix it if it is affected.

What it is: CVE-2012-3527 is a medium-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 5 Sep 2012. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-3527 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms (Packagist): affected from 4.5.0; fixed in 4.5.19
- typo3/cms (Packagist): affected from 4.5.0; fixed in 4.5.19
- typo3/cms (Packagist): affected from 4.6.0; fixed in 4.6.12
- typo3/cms (Packagist): affected from 4.6.0; fixed in 4.6.12
- typo3/cms (Packagist): affected from 4.7.0; fixed in 4.7.4
- typo3/cms (Packagist): affected from 4.7.0; fixed in 4.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-3527/ (Markdown: https://insights.sbomify.com/CVE-2012-3527/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-3527
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-3527
- OSV: https://osv.dev/vulnerability/CVE-2012-3527

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-3527/
Summaries are generated and may contain mistakes; the official description above is the record.
