CVE-2012-3528 Typo3 Backend XSS Vulnerability

Low 3.5 Published Updated

Authenticated backend users can inject arbitrary scripts into TYPO3, potentially compromising other users' sessions or data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2012-3528?

CVE-2012-3528 is a low-severity cross-site scripting vulnerability in Typo3 Typo3, published on 5 Sep 2012. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Multiple cross-site scripting (XSS) vulnerabilities in the backend in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allow remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79

Which versions are affected by CVE-2012-3528?

6 open source packages ship an affected version, including typo3/cms. It affects 1 product.

PackageAffectedFixed in
typo3/cms PackagistFrom 4.54.5.19
typo3/cms PackagistFrom 4.54.5.19
typo3/cms PackagistFrom 4.64.6.12
typo3/cms PackagistFrom 4.64.6.12
typo3/cms PackagistFrom 4.74.7.4
typo3/cms PackagistFrom 4.74.7.4

Products include Typo3 Typo3.

How do I fix CVE-2012-3528?

Upgrade typo3/cms to a fixed version for your release line: 4.5.19, 4.6.12 or 4.7.4.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2012-3528 being exploited?

There is no known exploitation of CVE-2012-3528 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as GHSA-7w6c-5pr4-7qvp.

Is CVE-2012-3528 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free