# CVE-2012-3530: Typo3 API XSS Vulnerability

> Remote attackers can execute arbitrary scripts in victim browsers via XSS in TYPO3's quoteJSvalue function, requiring user interaction.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Sep 2012
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-94c2-g68f-9r98

## What is CVE-2012-3530?

CVE-2012-3530 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 5 Sep 2012. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Incomplete blacklist vulnerability in the t3lib_div::quoteJSvalue API function in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allows remote attackers to conduct cross-site scripting (XSS) attacks via certain HTML5 JavaScript events.

## Which versions are affected by CVE-2012-3530?

6 open source packages ship an affected version, including typo3/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms` | Packagist | From 4.5 | 4.5.19 |
| `typo3/cms` | Packagist | From 4.5 | 4.5.19 |
| `typo3/cms` | Packagist | From 4.6 | 4.6.12 |
| `typo3/cms` | Packagist | From 4.6 | 4.6.12 |
| `typo3/cms` | Packagist | From 4.7 | 4.7.4 |
| `typo3/cms` | Packagist | From 4.7 | 4.7.4 |

Products: Typo3 Typo3.

## How do I fix CVE-2012-3530?

Upgrade typo3/cms to a fixed version for your release line: 4.5.19, 4.6.12 or 4.7.4.

## Is CVE-2012-3530 being exploited?

There is no known exploitation of CVE-2012-3530 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-3530 and fix it if it is affected.

What it is: CVE-2012-3530 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 5 Sep 2012. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2012-3530 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms (Packagist): affected from 4.5; fixed in 4.5.19
- typo3/cms (Packagist): affected from 4.5; fixed in 4.5.19
- typo3/cms (Packagist): affected from 4.6; fixed in 4.6.12
- typo3/cms (Packagist): affected from 4.6; fixed in 4.6.12
- typo3/cms (Packagist): affected from 4.7; fixed in 4.7.4
- typo3/cms (Packagist): affected from 4.7; fixed in 4.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-3530/ (Markdown: https://insights.sbomify.com/CVE-2012-3530/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-3530
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-3530
- OSV: https://osv.dev/vulnerability/CVE-2012-3530

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-3530/
Summaries are generated and may contain mistakes; the official description above is the record.
