# CVE-2012-3536: Apache James Hupa Webmail application Cross-site Scripting Vulnerabilities

> Attackers can execute arbitrary scripts in users' browsers via crafted emails in Apache Hupa Webmail, potentially leading to session hijacking.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Feb 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-7crp-p2vc-69r7

## What is CVE-2012-3536?

CVE-2012-3536 is a medium-severity cross-site scripting vulnerability in Apache Hupa, published on 27 Feb 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Two XSS vulnerabilities were fixed in message list and view in the Hupa Webmail application from the Apache James project. An attacker could send a carefully crafted email to a user of Hupa which would trigger a XSS when the email was opened or when a list of messages were viewed. This issue was addressed in Hupa 0.0.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2012-3536?

2 open source packages ship an affected version, including org.apache.james.hupa:hupa-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.james.hupa:hupa-parent` | Maven | All versions | 0.0.3 |
| `org.apache.james.hupa:hupa-parent` | Maven | All versions | 0.0.3 |

Products: Apache Hupa.

## How do I fix CVE-2012-3536?

Upgrade org.apache.james.hupa:hupa-parent to 0.0.3 or later.

## Is CVE-2012-3536 being exploited?

There is no known exploitation of CVE-2012-3536 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-3536 and fix it if it is affected.

What it is: CVE-2012-3536 is a medium-severity cross-site scripting vulnerability in Apache Hupa, published on 27 Feb 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2012-3536 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.james.hupa:hupa-parent (Maven): affected all versions; fixed in 0.0.3
- org.apache.james.hupa:hupa-parent (Maven): affected all versions; fixed in 0.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-3536/ (Markdown: https://insights.sbomify.com/CVE-2012-3536/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-3536
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-3536
- OSV: https://osv.dev/vulnerability/CVE-2012-3536

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-3536/
Summaries are generated and may contain mistakes; the official description above is the record.
