CVE-2012-3865 Puppet vulnerable to Path Traversal
Authenticated attackers can delete arbitrary files on the Puppet master server via path traversal when Delete is enabled in auth.conf.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2012-3865?
CVE-2012-3865 is a low-severity path traversal vulnerability in Puppet Puppet Enterprise, published on 6 Aug 2012. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Directory traversal vulnerability in lib/puppet/reports/store.rb in Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, when Delete is enabled in auth.conf, allows remote authenticated users to delete arbitrary files on the puppet master server via a .. (dot dot) in a node name.
Weakness: CWE-22
Which versions are affected by CVE-2012-3865?
4 open source packages ship an affected version, including puppet. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
puppet RubyGems | All versions | 2.6.17 |
puppet RubyGems | All versions | 2.6.17 |
puppet RubyGems | From 2.7.0 | 2.7.18 |
puppet RubyGems | From 2.7.0 | 2.7.18 |
Products include Puppet Puppet, Puppet Puppet Enterprise, Puppetlabs Puppet.
How do I fix CVE-2012-3865?
Upgrade puppet to a fixed version for your release line: 2.6.17 or 2.7.18.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2012-3865 being exploited?
There is no known exploitation of CVE-2012-3865 in the wild and no public exploit code.
Other vulnerabilities in Puppet Puppet Enterprise
Sources
Also known as DEBIAN-CVE-2012-3865, GHSA-g89m-3wjw-h857.