{"answers":{"affected":"4 open source packages ship an affected version, including puppet. It affects 3 products.","exploited":"There is no known exploitation of CVE-2012-3865 in the wild and no public exploit code.","fix":"Upgrade puppet to a fixed version for your release line: 2.6.17 or 2.7.18.","what":"CVE-2012-3865 is a low-severity path traversal vulnerability in Puppet Puppet Enterprise, published on 6 Aug 2012. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2012-3865 and fix it if it is affected.\n\nWhat it is: CVE-2012-3865 is a low-severity path traversal vulnerability in Puppet Puppet Enterprise, published on 6 Aug 2012. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2012-3865 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- puppet (RubyGems): affected all versions; fixed in 2.6.17\n- puppet (RubyGems): affected all versions; fixed in 2.6.17\n- puppet (RubyGems): affected from 2.7.0; fixed in 2.7.18\n- puppet (RubyGems): affected from 2.7.0; fixed in 2.7.18\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-3865/ (Markdown: https://insights.sbomify.com/CVE-2012-3865/index.md)","id":"CVE-2012-3865","markdown":"https://insights.sbomify.com/CVE-2012-3865/index.md","name":"CVE-2012-3865","record":{"aliases":["DEBIAN-CVE-2012-3865","GHSA-g89m-3wjw-h857"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Puppet configuration management","requires_auth":"low_privilege","summary":"Authenticated attackers can delete arbitrary files on the Puppet master server via path traversal when Delete is enabled in auth.conf.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"puppet","vendor":"puppet"},{"product":"puppet_enterprise","vendor":"puppet"},{"product":"puppet","vendor":"puppetlabs"}],"cvss":{"score":3.5,"severity":"low","source":"nvd","vector":"AV:N/AC:M/Au:S/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Directory traversal vulnerability in lib/puppet/reports/store.rb in Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, when Delete is enabled in auth.conf, allows remote authenticated users to delete arbitrary files on the puppet master server via a .. (dot dot) in a node name.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Puppet vulnerable to Path Traversal","id":"CVE-2012-3865","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"puppet:puppet_enterprise","products":["puppet:puppet_enterprise"],"type":"path_traversal","year":"2012"},"n_packages":4,"n_references":9,"next":{"headline":"Puppet allows local users to obtain sensitive configuration information","id":"CVE-2012-3866"},"packages":[{"ecosystem":"RubyGems","fixed":["2.6.17"],"introduced":["0"],"last_affected":[],"package":"puppet","purl":null,"source":"GHSA-g89m-3wjw-h857"},{"ecosystem":"RubyGems","fixed":["2.6.17"],"introduced":["0"],"last_affected":[],"package":"puppet","purl":"pkg:gem/puppet","source":"GHSA-g89m-3wjw-h857"},{"ecosystem":"RubyGems","fixed":["2.7.18"],"introduced":["2.7.0"],"last_affected":[],"package":"puppet","purl":null,"source":"GHSA-g89m-3wjw-h857"},{"ecosystem":"RubyGems","fixed":["2.7.18"],"introduced":["2.7.0"],"last_affected":[],"package":"puppet","purl":"pkg:gem/puppet","source":"GHSA-g89m-3wjw-h857"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2012-3864"},"products":["n/a"],"published":"2012-08-06","related":[{"cvss_score":9.8,"headline":"Puppet Improper Access Control","id":"CVE-2016-2785","kev_date_added":null,"published":"2016-06-10"},{"cvss_score":8.8,"headline":"SQL injection in Puppet DB","id":"CVE-2021-27021","kev_date_added":null,"published":"2021-07-20"},{"cvss_score":8.8,"headline":"Privilege escalation in Puppet Enterprise and Puppet Agent","id":"CVE-2018-6513","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.8,"headline":"Privilege escalation in Puppet Agent","id":"CVE-2018-6514","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.8,"headline":"Code injection in Puppet Agent","id":"CVE-2018-6515","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.5,"headline":"Puppet Improper Input Validation vulnerability","id":"CVE-2013-1655","kev_date_added":null,"published":"2013-03-20"},{"cvss_score":6.9,"headline":"Puppet Privilege Escallation","id":"CVE-2012-1053","kev_date_added":null,"published":"2012-05-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated attackers can delete arbitrary files on the Puppet master server via path traversal when Delete is enabled in auth.conf.","url":"https://insights.sbomify.com/CVE-2012-3865/"}