# CVE-2012-3865: Puppet vulnerable to Path Traversal

> Authenticated attackers can delete arbitrary files on the Puppet master server via path traversal when Delete is enabled in auth.conf.

- **Severity:** Low 3.5 (`AV:N/AC:M/Au:S/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2012
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2012-3865, GHSA-g89m-3wjw-h857

## What is CVE-2012-3865?

CVE-2012-3865 is a low-severity path traversal vulnerability in Puppet Puppet Enterprise, published on 6 Aug 2012. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Directory traversal vulnerability in lib/puppet/reports/store.rb in Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, when Delete is enabled in auth.conf, allows remote authenticated users to delete arbitrary files on the puppet master server via a .. (dot dot) in a node name.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2012-3865?

4 open source packages ship an affected version, including puppet. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `puppet` | RubyGems | All versions | 2.6.17 |
| `puppet` | RubyGems | All versions | 2.6.17 |
| `puppet` | RubyGems | From 2.7.0 | 2.7.18 |
| `puppet` | RubyGems | From 2.7.0 | 2.7.18 |

Products: Puppet Puppet, Puppet Puppet Enterprise, Puppetlabs Puppet.

## How do I fix CVE-2012-3865?

Upgrade puppet to a fixed version for your release line: 2.6.17 or 2.7.18.

## Is CVE-2012-3865 being exploited?

There is no known exploitation of CVE-2012-3865 in the wild and no public exploit code.

## Other vulnerabilities in Puppet Puppet Enterprise

- [CVE-2016-2785](https://insights.sbomify.com/CVE-2016-2785/): Puppet Improper Access Control (critical 9.8)
- [CVE-2021-27021](https://insights.sbomify.com/CVE-2021-27021/): SQL injection in Puppet DB (high 8.8)
- [CVE-2018-6513](https://insights.sbomify.com/CVE-2018-6513/): Privilege escalation in Puppet Enterprise and Puppet Agent (high 8.8)
- [CVE-2018-6514](https://insights.sbomify.com/CVE-2018-6514/): Privilege escalation in Puppet Agent (high 7.8)
- [CVE-2018-6515](https://insights.sbomify.com/CVE-2018-6515/): Code injection in Puppet Agent (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-3865 and fix it if it is affected.

What it is: CVE-2012-3865 is a low-severity path traversal vulnerability in Puppet Puppet Enterprise, published on 6 Aug 2012. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-3865 in the wild and no public exploit code.

Affected packages and fixed versions:
- puppet (RubyGems): affected all versions; fixed in 2.6.17
- puppet (RubyGems): affected all versions; fixed in 2.6.17
- puppet (RubyGems): affected from 2.7.0; fixed in 2.7.18
- puppet (RubyGems): affected from 2.7.0; fixed in 2.7.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-3865/ (Markdown: https://insights.sbomify.com/CVE-2012-3865/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-3865
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-3865
- OSV: https://osv.dev/vulnerability/CVE-2012-3865

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-3865/
Summaries are generated and may contain mistakes; the official description above is the record.
