CVE-2012-3867 Pupper does not properly restrict characters in Common Name field of Certificate Signing Request
Attackers can trick administrators into signing malicious certificates by exploiting insufficient input validation in Puppet's CSR Common Name field.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2012-3867?
CVE-2012-3867 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 6 Aug 2012. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
lib/puppet/ssl/certificate_authority.rb in Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, does not properly restrict the characters in the Common Name field of a Certificate Signing Request (CSR), which makes it easier for user-assisted remote attackers to trick administrators into signing a crafted agent certificate via ANSI control sequences.
Weakness: CWE-264
Which versions are affected by CVE-2012-3867?
4 open source packages ship an affected version, including puppet. It affects 8 products.
| Package | Affected | Fixed in |
|---|---|---|
puppet RubyGems | All versions | 2.6.17 |
puppet RubyGems | All versions | 2.6.17 |
puppet RubyGems | From 2.7.0 | 2.7.18 |
puppet RubyGems | From 2.7.0 | 2.7.18 |
Products include Canonical Ubuntu Linux, Debian Debian Linux, Opensuse Opensuse, Puppet Puppet, Puppet Puppet Enterprise, Puppetlabs Puppet and 2 more.
How do I fix CVE-2012-3867?
Upgrade puppet to a fixed version for your release line: 2.6.17 or 2.7.18.
Is CVE-2012-3867 being exploited?
There is no known exploitation of CVE-2012-3867 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2012-3867, GHSA-q44r-f2hm-v76v.