{"answers":{"affected":"4 open source packages ship an affected version, including puppet. It affects 8 products.","exploited":"There is no known exploitation of CVE-2012-3867 in the wild and no public exploit code.","fix":"Upgrade puppet to a fixed version for your release line: 2.6.17 or 2.7.18.","what":"CVE-2012-3867 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 6 Aug 2012. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2012-3867 and fix it if it is affected.\n\nWhat it is: CVE-2012-3867 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 6 Aug 2012. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2012-3867 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- puppet (RubyGems): affected all versions; fixed in 2.6.17\n- puppet (RubyGems): affected all versions; fixed in 2.6.17\n- puppet (RubyGems): affected from 2.7.0; fixed in 2.7.18\n- puppet (RubyGems): affected from 2.7.0; fixed in 2.7.18\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-3867/ (Markdown: https://insights.sbomify.com/CVE-2012-3867/index.md)","id":"CVE-2012-3867","markdown":"https://insights.sbomify.com/CVE-2012-3867/index.md","name":"CVE-2012-3867","record":{"aliases":["DEBIAN-CVE-2012-3867","GHSA-q44r-f2hm-v76v"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Puppet configuration management","requires_auth":"low_privilege","summary":"Attackers can trick administrators into signing malicious certificates by exploiting insufficient input validation in Puppet's CSR Common Name field.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"opensuse","vendor":"opensuse"},{"product":"puppet","vendor":"puppet"},{"product":"puppet_enterprise","vendor":"puppet"},{"product":"puppet","vendor":"puppetlabs"},{"product":"linux_enterprise_desktop","vendor":"suse"},{"product":"linux_enterprise_server","vendor":"suse"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"lib/puppet/ssl/certificate_authority.rb in Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, does not properly restrict the characters in the Common Name field of a Certificate Signing Request (CSR), which makes it easier for user-assisted remote attackers to trick administrators into signing a crafted agent certificate via ANSI control sequences.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pupper does not properly restrict characters in Common Name field of Certificate Signing Request","id":"CVE-2012-3867","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","opensuse:opensuse","puppet:puppet_enterprise","suse:linux_enterprise_desktop","suse:linux_enterprise_server"],"type":"security_feature_bypass","year":"2012"},"n_packages":4,"n_references":9,"next":{"headline":"Race condition in n/a","id":"CVE-2012-3868"},"packages":[{"ecosystem":"RubyGems","fixed":["2.6.17"],"introduced":["0"],"last_affected":[],"package":"puppet","purl":null,"source":"GHSA-q44r-f2hm-v76v"},{"ecosystem":"RubyGems","fixed":["2.6.17"],"introduced":["0"],"last_affected":[],"package":"puppet","purl":"pkg:gem/puppet","source":"GHSA-q44r-f2hm-v76v"},{"ecosystem":"RubyGems","fixed":["2.7.18"],"introduced":["2.7.0"],"last_affected":[],"package":"puppet","purl":null,"source":"GHSA-q44r-f2hm-v76v"},{"ecosystem":"RubyGems","fixed":["2.7.18"],"introduced":["2.7.0"],"last_affected":[],"package":"puppet","purl":"pkg:gem/puppet","source":"GHSA-q44r-f2hm-v76v"}],"prev":{"headline":"Puppet allows local users to obtain sensitive configuration information","id":"CVE-2012-3866"},"products":["n/a"],"published":"2012-08-06","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can trick administrators into signing malicious certificates by exploiting insufficient input validation in Puppet's CSR Common Name field.","url":"https://insights.sbomify.com/CVE-2012-3867/"}