# CVE-2012-3867: Pupper does not properly restrict characters in Common Name field of Certificate Signing Request

> Attackers can trick administrators into signing malicious certificates by exploiting insufficient input validation in Puppet's CSR Common Name field.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Aug 2012
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2012-3867, GHSA-q44r-f2hm-v76v

## What is CVE-2012-3867?

CVE-2012-3867 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 6 Aug 2012. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

lib/puppet/ssl/certificate_authority.rb in Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, does not properly restrict the characters in the Common Name field of a Certificate Signing Request (CSR), which makes it easier for user-assisted remote attackers to trick administrators into signing a crafted agent certificate via ANSI control sequences.

Weakness: CWE-264

## Which versions are affected by CVE-2012-3867?

4 open source packages ship an affected version, including puppet. It affects 8 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `puppet` | RubyGems | All versions | 2.6.17 |
| `puppet` | RubyGems | All versions | 2.6.17 |
| `puppet` | RubyGems | From 2.7.0 | 2.7.18 |
| `puppet` | RubyGems | From 2.7.0 | 2.7.18 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Opensuse Opensuse, Puppet Puppet, Puppet Puppet Enterprise, Puppetlabs Puppet, Suse Linux Enterprise Desktop, Suse Linux Enterprise Server.

## How do I fix CVE-2012-3867?

Upgrade puppet to a fixed version for your release line: 2.6.17 or 2.7.18.

## Is CVE-2012-3867 being exploited?

There is no known exploitation of CVE-2012-3867 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-3867 and fix it if it is affected.

What it is: CVE-2012-3867 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 6 Aug 2012. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2012-3867 in the wild and no public exploit code.

Affected packages and fixed versions:
- puppet (RubyGems): affected all versions; fixed in 2.6.17
- puppet (RubyGems): affected all versions; fixed in 2.6.17
- puppet (RubyGems): affected from 2.7.0; fixed in 2.7.18
- puppet (RubyGems): affected from 2.7.0; fixed in 2.7.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-3867/ (Markdown: https://insights.sbomify.com/CVE-2012-3867/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-3867
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-3867
- OSV: https://osv.dev/vulnerability/CVE-2012-3867

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-3867/
Summaries are generated and may contain mistakes; the official description above is the record.
