CVE-2012-4345 phpMyAdmin Multiple Cross-site Scripting Vulnerabilities in the Database Structure page
Authenticated users can inject arbitrary scripts via crafted table names in phpMyAdmin, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2012-4345?
CVE-2012-4345 is a low-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 21 Aug 2012. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in the Database Structure page in phpMyAdmin 3.4.x before 3.4.11.1 and 3.5.x before 3.5.2.2 allow remote authenticated users to inject arbitrary web script or HTML via (1) a crafted table name during table creation, or a (2) Empty link or (3) Drop link for a crafted table name.
Weakness: CWE-79
Which versions are affected by CVE-2012-4345?
4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 3.4 | 3.4.11.1 |
phpmyadmin/phpmyadmin Packagist | From 3.4 | 3.4.11.1 |
phpmyadmin/phpmyadmin Packagist | From 3.5 | 3.5.2.2 |
phpmyadmin/phpmyadmin Packagist | From 3.5 | 3.5.2.2 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2012-4345?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 3.4.11.1 or 3.5.2.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2012-4345 being exploited?
There is no known exploitation of CVE-2012-4345 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as DEBIAN-CVE-2012-4345, GHSA-r3pq-mp8v-cp33.