{"answers":{"affected":"4 open source packages ship an affected version, including cakephp/cakephp. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2012-4399 exists.","fix":"Upgrade cakephp/cakephp to a fixed version for your release line: 2.1.5 or 2.2.1.","what":"CVE-2012-4399 is a high-severity vulnerability in n/a, published on 9 Oct 2012. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2012-4399 and fix it if it is affected.\n\nWhat it is: CVE-2012-4399 is a high-severity vulnerability in n/a, published on 9 Oct 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2012-4399 exists.\n\nAffected packages and fixed versions:\n- cakephp/cakephp (Packagist): affected from 2.1.0-alpha; fixed in 2.1.5\n- cakephp/cakephp (Packagist): affected from 2.1.0-alpha; fixed in 2.1.5\n- cakephp/cakephp (Packagist): affected from 2.2.0-beta; fixed in 2.2.1\n- cakephp/cakephp (Packagist): affected from 2.2.0-beta; fixed in 2.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-4399/ (Markdown: https://insights.sbomify.com/CVE-2012-4399/index.md)","id":"CVE-2012-4399","markdown":"https://insights.sbomify.com/CVE-2012-4399/index.md","name":"CVE-2012-4399","record":{"aliases":["GHSA-5964-pq8r-4q62"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"CakePHP framework","requires_auth":"none","summary":"Remote attackers can read arbitrary files via XML external entity injection in the CakePHP Xml class.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"cakephp","vendor":"cakefoundation"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"The Xml class in CakePHP 2.1.x before 2.1.5 and 2.2.x before 2.2.1 allows remote attackers to read arbitrary files via XML data containing external entity references, aka an XML external entity (XXE) injection attack.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2012-07-16","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2012-07-16","kind":"exploitdb","ref":"19863","stars":null,"title":"CakePHP 2.x \u003c 2.2.0-RC2 - XML External Entity Injection"}],"tier":"weaponised"},"has_fix":true,"headline":"CakePHPallows remote attackers to read arbitrary files via XML data containing external entity references","id":"CVE-2012-4399","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xxe","year":"2012"},"n_packages":4,"n_references":7,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2012-4400"},"packages":[{"ecosystem":"Packagist","fixed":["2.1.5"],"introduced":["2.1.0-alpha"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-5964-pq8r-4q62"},{"ecosystem":"Packagist","fixed":["2.1.5"],"introduced":["2.1.0-alpha"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-5964-pq8r-4q62"},{"ecosystem":"Packagist","fixed":["2.2.1"],"introduced":["2.2.0-beta"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-5964-pq8r-4q62"},{"ecosystem":"Packagist","fixed":["2.2.1"],"introduced":["2.2.0-beta"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-5964-pq8r-4q62"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2012-4398"},"products":["n/a"],"published":"2012-10-09","related":[{"cvss_score":7.5,"headline":"CakePHP allows remote attackers to modify internal Cake cache and execute arbitrary code","id":"CVE-2010-4335","kev_date_added":null,"published":"2011-01-14"},{"cvss_score":4.3,"headline":"Cross-Site Request Forgery in CakePHP","id":"CVE-2020-15400","kev_date_added":null,"published":"2020-06-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Remote attackers can read arbitrary files via XML external entity injection in the CakePHP Xml class.","url":"https://insights.sbomify.com/CVE-2012-4399/"}