# CVE-2012-4406: OpenStack Object Storage (swift) Code Injection vulnerability

> Remote attackers can execute arbitrary code in OpenStack Object Storage by sending crafted pickle objects to memcached.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Oct 2012
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2012-4406, GHSA-v7mh-3jgf-r26c, PYSEC-2026-545, RHSA-2012:1379

## What is CVE-2012-4406?

CVE-2012-4406 is a critical unsafe deserialization vulnerability in Fedoraproject Fedora, published on 22 Oct 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenStack Object Storage (swift) before 1.7.0 uses the loads function in the pickle Python module unsafely when storing and loading metadata in memcached, which allows remote attackers to execute arbitrary code via a crafted pickle object.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2012-4406?

3 open source packages ship an affected version, including swift. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `swift` | PyPI | All versions | 1.7.0 |
| `swift` | PyPI | All versions | 1.7.0 |
| `swift` | PyPI | All versions | 1.7.0 |
| `openstack-swift` | Red Hat:openstack:1::el6 | All versions | 0:1.4.8-5.el6 |
| `openstack-swift-account` | Red Hat:openstack:1::el6 | All versions | 0:1.4.8-5.el6 |
| `openstack-swift-container` | Red Hat:openstack:1::el6 | All versions | 0:1.4.8-5.el6 |
| `openstack-swift-doc` | Red Hat:openstack:1::el6 | All versions | 0:1.4.8-5.el6 |
| `openstack-swift-object` | Red Hat:openstack:1::el6 | All versions | 0:1.4.8-5.el6 |
| `openstack-swift-proxy` | Red Hat:openstack:1::el6 | All versions | 0:1.4.8-5.el6 |

Products: Fedoraproject Fedora, Openstack Swift, Redhat Enterprise Linux Server, Redhat Gluster Storage Management Console, Redhat Gluster Storage Server for On-Premise, Redhat Storage, Redhat Storage for Public Cloud.

## How do I fix CVE-2012-4406?

Upgrade swift to 1.7.0 or later.

## Is CVE-2012-4406 being exploited?

There is no known exploitation of CVE-2012-4406 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-4406 and fix it if it is affected.

What it is: CVE-2012-4406 is a critical unsafe deserialization vulnerability in Fedoraproject Fedora, published on 22 Oct 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-4406 in the wild and no public exploit code.

Affected packages and fixed versions:
- swift (PyPI): affected all versions; fixed in 1.7.0
- swift (PyPI): affected all versions; fixed in 1.7.0
- swift (PyPI): affected all versions; fixed in 1.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-4406/ (Markdown: https://insights.sbomify.com/CVE-2012-4406/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-4406
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-4406
- OSV: https://osv.dev/vulnerability/CVE-2012-4406

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-4406/
Summaries are generated and may contain mistakes; the official description above is the record.
