CVE-2012-4438 Jenkins allows Data Insertion and Execution of Code by those with Read and HTTP Access

High 8.8 Published Updated

Remote attackers with read access can inject data to execute arbitrary code on the Jenkins master server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2012-4438?

CVE-2012-4438 is a high-severity code injection vulnerability in Jenkins Jenkins, published on 18 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Jenkins main before 1.482 and LTS before 1.466.2 allows remote attackers with read access and HTTP access to Jenkins master to insert data and execute arbitrary code.

Weakness: CWE-20

Which versions are affected by CVE-2012-4438?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.466.2
org.jenkins-ci.main:jenkins-core MavenAll versions1.466.2
org.jenkins-ci.main:jenkins-core MavenFrom 1.4671.482
org.jenkins-ci.main:jenkins-core MavenFrom 1.4671.482

Products include Jenkins Jenkins.

How do I fix CVE-2012-4438?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.466.2 or 1.482.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2012-4438 being exploited?

There is no known exploitation of CVE-2012-4438 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-wr6p-j63r-xqhv.

Is CVE-2012-4438 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free