# CVE-2012-4438: Jenkins allows Data Insertion and Execution of Code by those with Read and HTTP Access

> Remote attackers with read access can inject data to execute arbitrary code on the Jenkins master server.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Nov 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-wr6p-j63r-xqhv

## What is CVE-2012-4438?

CVE-2012-4438 is a high-severity code injection vulnerability in Jenkins Jenkins, published on 18 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins main before 1.482 and LTS before 1.466.2 allows remote attackers with read access and HTTP access to Jenkins master to insert data and execute arbitrary code.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2012-4438?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 1.466.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 1.466.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 1.467 | 1.482 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 1.467 | 1.482 |

Products: Jenkins Jenkins.

## How do I fix CVE-2012-4438?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.466.2 or 1.482.

## Is CVE-2012-4438 being exploited?

There is no known exploitation of CVE-2012-4438 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-4438 and fix it if it is affected.

What it is: CVE-2012-4438 is a high-severity code injection vulnerability in Jenkins Jenkins, published on 18 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-4438 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.466.2
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.466.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.467; fixed in 1.482
- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.467; fixed in 1.482

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-4438/ (Markdown: https://insights.sbomify.com/CVE-2012-4438/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-4438
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-4438
- OSV: https://osv.dev/vulnerability/CVE-2012-4438

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-4438/
Summaries are generated and may contain mistakes; the official description above is the record.
