{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:violations. It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-4440 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:violations to 0.7.11 or later.","what":"CVE-2012-4440 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 18 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2012-4440 and fix it if it is affected.\n\nWhat it is: CVE-2012-4440 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 18 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2012-4440 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:violations (Maven): affected all versions; fixed in 0.7.11\n- org.jenkins-ci.plugins:violations (Maven): affected all versions; fixed in 0.7.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-4440/ (Markdown: https://insights.sbomify.com/CVE-2012-4440/index.md)","id":"CVE-2012-4440","markdown":"https://insights.sbomify.com/CVE-2012-4440/index.md","name":"CVE-2012-4440","record":{"aliases":["GHSA-5qpv-27q3-6484"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins CI server","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML into the Violations plugin, potentially compromising user sessions or executing malicious code.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"jenkins","vendor":"jenkins"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site Scripting (XSS) in Jenkins main before 1.482 and LTS before 1.466.2 allows remote attackers to inject arbitrary web script or HTML in the Violations plugin.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Violation Plugin allows Cross-Site Scripting (XSS)","id":"CVE-2012-4440","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"jenkins:jenkins","products":["jenkins:jenkins"],"type":"xss","year":"2012"},"n_packages":2,"n_references":3,"next":{"headline":"Jenkins CI Game Plugin allows Cross-Site Scripting (XSS)","id":"CVE-2012-4441"},"packages":[{"ecosystem":"Maven","fixed":["0.7.11"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:violations","purl":null,"source":"GHSA-5qpv-27q3-6484"},{"ecosystem":"Maven","fixed":["0.7.11"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:violations","purl":"pkg:maven/org.jenkins-ci.plugins/violations","source":"GHSA-5qpv-27q3-6484"}],"prev":{"headline":"Jenkins allows Cross-Site Scripting (XSS) via Crafted URL","id":"CVE-2012-4439"},"products":["jenkins"],"published":"2019-11-18","related":[{"cvss_score":9.8,"headline":"Jenkins Command Line Interface (CLI) Path Traversal","id":"CVE-2024-23897","kev_date_added":"2024-08-19","published":"2024-01-24"},{"cvss_score":9.8,"headline":"Jenkins Stapler Web Framework Deserialization of Untrusted Data","id":"CVE-2018-1000861","kev_date_added":"2022-02-10","published":"2018-12-10"},{"cvss_score":9.8,"headline":"Jenkins Remote Code Execution","id":"CVE-2017-1000353","kev_date_added":"2025-10-02","published":"2018-01-29"},{"cvss_score":7.5,"headline":"Jenkins User Interface (UI) Information Disclosure","id":"CVE-2015-5317","kev_date_added":"2023-05-12","published":"2015-11-25"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21690","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21691","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21692","kev_date_added":null,"published":"2021-11-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["jenkins"]},"summary":"Remote attackers can inject arbitrary web script or HTML into the Violations plugin, potentially compromising user sessions or executing malicious code.","url":"https://insights.sbomify.com/CVE-2012-4440/"}