CVE-2012-4449 Use of a Broken or Risky Cryptographic Algorithm in Apache Hadoop
Attackers can brute-force weak 20-bit token passwords in Hadoop Kerberos configurations to bypass security controls.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2012-4449?
CVE-2012-4449 is a critical vulnerability in n/a, published on 30 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Hadoop before 0.23.4, 1.x before 1.0.4, and 2.x before 2.0.2 generate token passwords using a 20-bit secret when Kerberos security features are enabled, which makes it easier for context-dependent attackers to crack secret keys via a brute-force attack.
Weakness: CWE-327
Which versions are affected by CVE-2012-4449?
6 open source packages ship an affected version, including org.apache.hadoop:hadoop-client. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.hadoop:hadoop-client Maven | All versions | 0.23.4 |
org.apache.hadoop:hadoop-client Maven | All versions | 0.23.4 |
org.apache.hadoop:hadoop-client Maven | From 1.0.0 | 1.0.4 |
org.apache.hadoop:hadoop-client Maven | From 1.0.0 | 1.0.4 |
org.apache.hadoop:hadoop-client Maven | From 2.0.0 | 2.0.2 |
org.apache.hadoop:hadoop-client Maven | From 2.0.0 | 2.0.2 |
Products include Apache Hadoop.
How do I fix CVE-2012-4449?
Upgrade org.apache.hadoop:hadoop-client to a fixed version for your release line: 0.23.4, 1.0.4 or 2.0.2.
Is CVE-2012-4449 being exploited?
There is no known exploitation of CVE-2012-4449 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2022-25168 Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar
- CVE-2021-37404 Heap buffer overflow in libhdfs native library
- CVE-2022-26612 Arbitrary file write in FileUtil#unpackEntries on Windows
- CVE-2019-17195 Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT
- CVE-2017-15718 Exposure of Sensitive Information in Hadoop
Sources
Also known as GHSA-q46v-cj5v-hvg6.