# CVE-2012-4449: Use of a Broken or Risky Cryptographic Algorithm in Apache Hadoop

> Attackers can brute-force weak 20-bit token passwords in Hadoop Kerberos configurations to bypass security controls.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Oct 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-q46v-cj5v-hvg6

## What is CVE-2012-4449?

CVE-2012-4449 is a critical vulnerability in n/a, published on 30 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Hadoop before 0.23.4, 1.x before 1.0.4, and 2.x before 2.0.2 generate token passwords using a 20-bit secret when Kerberos security features are enabled, which makes it easier for context-dependent attackers to crack secret keys via a brute-force attack.

Weakness: CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2012-4449?

6 open source packages ship an affected version, including org.apache.hadoop:hadoop-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hadoop:hadoop-client` | Maven | All versions | 0.23.4 |
| `org.apache.hadoop:hadoop-client` | Maven | All versions | 0.23.4 |
| `org.apache.hadoop:hadoop-client` | Maven | From 1.0.0 | 1.0.4 |
| `org.apache.hadoop:hadoop-client` | Maven | From 1.0.0 | 1.0.4 |
| `org.apache.hadoop:hadoop-client` | Maven | From 2.0.0 | 2.0.2 |
| `org.apache.hadoop:hadoop-client` | Maven | From 2.0.0 | 2.0.2 |

Products: Apache Hadoop.

## How do I fix CVE-2012-4449?

Upgrade org.apache.hadoop:hadoop-client to a fixed version for your release line: 0.23.4, 1.0.4 or 2.0.2.

## Is CVE-2012-4449 being exploited?

There is no known exploitation of CVE-2012-4449 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-25168](https://insights.sbomify.com/CVE-2022-25168/): Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar (critical 9.8)
- [CVE-2021-37404](https://insights.sbomify.com/CVE-2021-37404/): Heap buffer overflow in libhdfs native library (critical 9.8)
- [CVE-2022-26612](https://insights.sbomify.com/CVE-2022-26612/): Arbitrary file write in FileUtil#unpackEntries on Windows (critical 9.8)
- [CVE-2019-17195](https://insights.sbomify.com/CVE-2019-17195/): Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT (critical 9.8)
- [CVE-2017-15718](https://insights.sbomify.com/CVE-2017-15718/): Exposure of Sensitive Information in Hadoop (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-4449 and fix it if it is affected.

What it is: CVE-2012-4449 is a critical vulnerability in n/a, published on 30 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-4449 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hadoop:hadoop-client (Maven): affected all versions; fixed in 0.23.4
- org.apache.hadoop:hadoop-client (Maven): affected all versions; fixed in 0.23.4
- org.apache.hadoop:hadoop-client (Maven): affected from 1.0.0; fixed in 1.0.4
- org.apache.hadoop:hadoop-client (Maven): affected from 1.0.0; fixed in 1.0.4
- org.apache.hadoop:hadoop-client (Maven): affected from 2.0.0; fixed in 2.0.2
- org.apache.hadoop:hadoop-client (Maven): affected from 2.0.0; fixed in 2.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-4449/ (Markdown: https://insights.sbomify.com/CVE-2012-4449/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-4449
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-4449
- OSV: https://osv.dev/vulnerability/CVE-2012-4449

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-4449/
Summaries are generated and may contain mistakes; the official description above is the record.
