# CVE-2012-4571: Python Keyring does not securely initialize encryption cipher

> Local attackers can brute-force passwords stored in CryptedFileKeyring files due to insecure cipher initialization in the Python Keyring library.

- **Severity:** Low 2.1 (`AV:L/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Nov 2012
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2012-4571, GHSA-p3h7-3c45-qj4v, PYSEC-2012-8

## What is CVE-2012-4571?

CVE-2012-4571 is a low-severity vulnerability in n/a, published on 30 Nov 2012. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Python Keyring 0.9.1 does not securely initialize the cipher when encrypting passwords for CryptedFileKeyring files, which makes it easier for local users to obtain passwords via a brute-force attack.

Weakness: CWE-310

## Which versions are affected by CVE-2012-4571?

3 open source packages ship an affected version, including keyring. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keyring` | PyPI | All versions | 0.9.2 |
| `keyring` | PyPI | All versions | 0.9.2 |
| `keyring` | PyPI | All versions | 0.9.2 |

Products: Python Keyring.

## How do I fix CVE-2012-4571?

Upgrade keyring to 0.9.2 or later.

## Is CVE-2012-4571 being exploited?

There is no known exploitation of CVE-2012-4571 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2012-5578](https://insights.sbomify.com/CVE-2012-5578/): Incorrect Default Permissions in keyring (medium 6.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-4571 and fix it if it is affected.

What it is: CVE-2012-4571 is a low-severity vulnerability in n/a, published on 30 Nov 2012. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-4571 in the wild and no public exploit code.

Affected packages and fixed versions:
- keyring (PyPI): affected all versions; fixed in 0.9.2
- keyring (PyPI): affected all versions; fixed in 0.9.2
- keyring (PyPI): affected all versions; fixed in 0.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-4571/ (Markdown: https://insights.sbomify.com/CVE-2012-4571/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-4571
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-4571
- OSV: https://osv.dev/vulnerability/CVE-2012-4571

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-4571/
Summaries are generated and may contain mistakes; the official description above is the record.
