# CVE-2012-4968: Silverstripe XSS Vulnerabilities

> Remote attackers can inject arbitrary web script or HTML via crafted strings in various template methods, potentially leading to session hijacking or data theft.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Sep 2012
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-v358-rvxr-wffx

## What is CVE-2012-4968?

CVE-2012-4968 is a medium-severity cross-site scripting vulnerability in Silverstripe Silverstripe, published on 17 Sep 2012. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in SilverStripe 2.3.x before 2.3.13 and 2.4.x before 2.4.7 allow remote attackers to inject arbitrary web script or HTML via (1) a crafted string to the AbsoluteLinks, (2) BigSummary, (3) ContextSummary, (4) EscapeXML, (5) FirstParagraph, (6) FirstSentence, (7) Initial, (8) LimitCharacters, (9) LimitSentences, (10) LimitWordCount, (11) LimitWordCountXML, (12) Lower, (13) LowerCase, (14) NoHTML, (15) Summary, (16) Upper, (17) UpperCase, or (18) URL method in a template, different vectors than CVE-2012-0976.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2012-4968?

4 open source packages ship an affected version, including silverstripe/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/framework` | Packagist | From 2.3 | 2.3.13 |
| `silverstripe/framework` | Packagist | From 2.3 | 2.3.13 |
| `silverstripe/framework` | Packagist | From 2.4 | 2.4.7 |
| `silverstripe/framework` | Packagist | From 2.4 | 2.4.7 |

Products: Silverstripe Silverstripe.

## How do I fix CVE-2012-4968?

Upgrade silverstripe/framework to a fixed version for your release line: 2.3.13 or 2.4.7.

## Is CVE-2012-4968 being exploited?

There is no known exploitation of CVE-2012-4968 in the wild and no public exploit code.

## Other vulnerabilities in Silverstripe Silverstripe

- [CVE-2007-2321](https://insights.sbomify.com/CVE-2007-2321/): Other in n/a (critical 10.0)
- [CVE-2019-12204](https://insights.sbomify.com/CVE-2019-12204/): Missing warning can lead to unauthenticated admin access in SilverStripe (critical 9.8)
- [CVE-2019-5715](https://insights.sbomify.com/CVE-2019-5715/): Silverstripe Framework SQLi Vulnerability (critical 9.8)
- [CVE-2019-12437](https://insights.sbomify.com/CVE-2019-12437/): Silverstripe CSRF Protection Bypass via GraphQL (high 8.8)
- [CVE-2020-6164](https://insights.sbomify.com/CVE-2020-6164/): Silverstripe CMS information disclosure (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-4968 and fix it if it is affected.

What it is: CVE-2012-4968 is a medium-severity cross-site scripting vulnerability in Silverstripe Silverstripe, published on 17 Sep 2012. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2012-4968 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/framework (Packagist): affected from 2.3; fixed in 2.3.13
- silverstripe/framework (Packagist): affected from 2.3; fixed in 2.3.13
- silverstripe/framework (Packagist): affected from 2.4; fixed in 2.4.7
- silverstripe/framework (Packagist): affected from 2.4; fixed in 2.4.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-4968/ (Markdown: https://insights.sbomify.com/CVE-2012-4968/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-4968
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-4968
- OSV: https://osv.dev/vulnerability/CVE-2012-4968

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-4968/
Summaries are generated and may contain mistakes; the official description above is the record.
