# CVE-2012-5055: Exposure of Sensitive Information to an Unauthorized Actor in Spring Security

> Remote attackers can enumerate valid usernames by observing response time differences in login attempts due to missing password checks for non-existent users.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Dec 2012
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-3533-rvpc-6x56

## What is CVE-2012-5055?

CVE-2012-5055 is a medium-severity vulnerability in n/a, published on 5 Dec 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DaoAuthenticationProvider in VMware SpringSource Spring Security before 2.0.8, 3.0.x before 3.0.8, and 3.1.x before 3.1.3 does not check the password if the user is not found, which makes the response delay shorter and might allow remote attackers to enumerate valid usernames via a series of login requests.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2012-5055?

6 open source packages ship an affected version, including org.springframework.security:spring-security-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-core` | Maven | All versions | 2.0.8 |
| `org.springframework.security:spring-security-core` | Maven | All versions | 2.0.8 |
| `org.springframework.security:spring-security-core` | Maven | From 3.0.0 | 3.0.8 |
| `org.springframework.security:spring-security-core` | Maven | From 3.0.0 | 3.0.8 |
| `org.springframework.security:spring-security-core` | Maven | From 3.1.0 | 3.1.3 |
| `org.springframework.security:spring-security-core` | Maven | From 3.1.0 | 3.1.3 |

Products: Vmware Springsource Spring Security.

## How do I fix CVE-2012-5055?

Upgrade org.springframework.security:spring-security-core to a fixed version for your release line: 2.0.8, 3.0.8 or 3.1.3.

## Is CVE-2012-5055 being exploited?

There is no known exploitation of CVE-2012-5055 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2011-2731](https://insights.sbomify.com/CVE-2011-2731/): Concurrent Execution using Shared Resource with Improper Synchronization in Spring Security (medium 5.1)
- [CVE-2011-2732](https://insights.sbomify.com/CVE-2011-2732/): Improper Control of Generation of Code in Spring Security (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-5055 and fix it if it is affected.

What it is: CVE-2012-5055 is a medium-severity vulnerability in n/a, published on 5 Dec 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-5055 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-core (Maven): affected all versions; fixed in 2.0.8
- org.springframework.security:spring-security-core (Maven): affected all versions; fixed in 2.0.8
- org.springframework.security:spring-security-core (Maven): affected from 3.0.0; fixed in 3.0.8
- org.springframework.security:spring-security-core (Maven): affected from 3.0.0; fixed in 3.0.8
- org.springframework.security:spring-security-core (Maven): affected from 3.1.0; fixed in 3.1.3
- org.springframework.security:spring-security-core (Maven): affected from 3.1.0; fixed in 3.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-5055/ (Markdown: https://insights.sbomify.com/CVE-2012-5055/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-5055
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-5055
- OSV: https://osv.dev/vulnerability/CVE-2012-5055

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-5055/
Summaries are generated and may contain mistakes; the official description above is the record.
