{"answers":{"affected":"2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-5181 in the wild and no public exploit code.","fix":"Upgrade concrete5/concrete5 to 5.6.1 or later.","what":"CVE-2012-5181 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Dec 2012. It can be exploited over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2012-5181 and fix it if it is affected.\n\nWhat it is: CVE-2012-5181 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Dec 2012. It can be exploited over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2012-5181 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- concrete5/concrete5 (Packagist): affected from 5.5.1; fixed in 5.6.1\n- concrete5/concrete5 (Packagist): affected from 5.5.1; fixed in 5.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-5181/ (Markdown: https://insights.sbomify.com/CVE-2012-5181/index.md)","id":"CVE-2012-5181","markdown":"https://insights.sbomify.com/CVE-2012-5181/index.md","name":"CVE-2012-5181","record":{"aliases":["GHSA-x4x9-4c65-73w8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"concrete5 CMS","requires_auth":"unknown","summary":"Remote attackers can inject arbitrary web script or HTML into concrete5 CMS, potentially compromising user sessions or data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[{"product":"concrete5","vendor":"concrete5"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in concrete5 Japanese 5.5.1 through 5.5.2.1 and concrete5 English 5.5.0 through 5.6.0.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Concrete5 Vulnerable to Cross-Site Scripting (XSS)","id":"CVE-2012-5181","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2012"},"n_packages":2,"n_references":3,"next":{"headline":"Information disclosure in n/a","id":"CVE-2012-5182"},"packages":[{"ecosystem":"Packagist","fixed":["5.6.1"],"introduced":["5.5.1"],"last_affected":[],"package":"concrete5/concrete5","purl":null,"source":"GHSA-x4x9-4c65-73w8"},{"ecosystem":"Packagist","fixed":["5.6.1"],"introduced":["5.5.1"],"last_affected":[],"package":"concrete5/concrete5","purl":"pkg:composer/concrete5/concrete5","source":"GHSA-x4x9-4c65-73w8"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2012-5180"},"products":["n/a"],"published":"2012-12-21","related":[{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2017-6905","kev_date_added":null,"published":"2017-03-15"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2017-6908","kev_date_added":null,"published":"2017-03-15"},{"cvss_score":5,"headline":"Information disclosure in n/a","id":"CVE-2014-5107","kev_date_added":null,"published":"2014-07-28"},{"cvss_score":4.3,"headline":"Cross-site scripting in n/a","id":"CVE-2015-2250","kev_date_added":null,"published":"2015-05-15"},{"cvss_score":4.3,"headline":"concrete5 vulnerable to Cross-site Scripting","id":"CVE-2015-3989","kev_date_added":null,"published":"2015-05-15"},{"cvss_score":4.3,"headline":"Cross-site scripting in n/a","id":"CVE-2014-9526","kev_date_added":null,"published":"2015-01-05"},{"cvss_score":4.3,"headline":"Cross-site scripting in n/a","id":"CVE-2014-5108","kev_date_added":null,"published":"2014-07-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML into concrete5 CMS, potentially compromising user sessions or data.","url":"https://insights.sbomify.com/CVE-2012-5181/"}