# CVE-2012-5181: Concrete5 Vulnerable to Cross-Site Scripting (XSS)

> Remote attackers can inject arbitrary web script or HTML into concrete5 CMS, potentially compromising user sessions or data.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Dec 2012
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-x4x9-4c65-73w8

## What is CVE-2012-5181?

CVE-2012-5181 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Dec 2012. It can be exploited over the network, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in concrete5 Japanese 5.5.1 through 5.5.2.1 and concrete5 English 5.5.0 through 5.6.0.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2012-5181?

2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concrete5/concrete5` | Packagist | From 5.5.1 | 5.6.1 |
| `concrete5/concrete5` | Packagist | From 5.5.1 | 5.6.1 |

Products: Concrete5 Concrete5.

## How do I fix CVE-2012-5181?

Upgrade concrete5/concrete5 to 5.6.1 or later.

## Is CVE-2012-5181 being exploited?

There is no known exploitation of CVE-2012-5181 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-6905](https://insights.sbomify.com/CVE-2017-6905/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2017-6908](https://insights.sbomify.com/CVE-2017-6908/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2014-5107](https://insights.sbomify.com/CVE-2014-5107/): Information disclosure in n/a (medium 5.0)
- [CVE-2015-2250](https://insights.sbomify.com/CVE-2015-2250/): Cross-site scripting in n/a (medium 4.3)
- [CVE-2015-3989](https://insights.sbomify.com/CVE-2015-3989/): concrete5 vulnerable to Cross-site Scripting (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-5181 and fix it if it is affected.

What it is: CVE-2012-5181 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Dec 2012. It can be exploited over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2012-5181 in the wild and no public exploit code.

Affected packages and fixed versions:
- concrete5/concrete5 (Packagist): affected from 5.5.1; fixed in 5.6.1
- concrete5/concrete5 (Packagist): affected from 5.5.1; fixed in 5.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-5181/ (Markdown: https://insights.sbomify.com/CVE-2012-5181/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-5181
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-5181
- OSV: https://osv.dev/vulnerability/CVE-2012-5181

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-5181/
Summaries are generated and may contain mistakes; the official description above is the record.
