# CVE-2012-5368: phpMyAdmin Unsafe Fetching of Javascript Code

> Man-in-the-middle attackers can inject malicious JavaScript into phpMyAdmin sessions via unencrypted HTTP requests, leading to cross-site scripting attacks.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Oct 2012
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-xpxp-v33m-5jp9

## What is CVE-2012-5368?

CVE-2012-5368 is a medium-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 25 Oct 2012. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

phpMyAdmin 3.5.x before 3.5.3 uses JavaScript code that is obtained through an HTTP session to phpmyadmin.net without SSL, which allows man-in-the-middle attackers to conduct cross-site scripting (XSS) attacks by modifying this code.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2012-5368?

2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 3.5 | 3.5.3 |
| `phpmyadmin/phpmyadmin` | Packagist | From 3.5 | 3.5.3 |

Products: Phpmyadmin Phpmyadmin.

## How do I fix CVE-2012-5368?

Upgrade phpmyadmin/phpmyadmin to 3.5.3 or later.

## Is CVE-2012-5368 being exploited?

There is no known exploitation of CVE-2012-5368 in the wild and no public exploit code.

## Other vulnerabilities in Phpmyadmin Phpmyadmin

- [CVE-2008-7251](https://insights.sbomify.com/CVE-2008-7251/): Misconfiguration in n/a (critical 10.0)
- [CVE-2008-7252](https://insights.sbomify.com/CVE-2008-7252/): phpMyAdmin unsafely handles temporary files (critical 10.0)
- [CVE-2007-0203](https://insights.sbomify.com/CVE-2007-0203/): Other in n/a (critical 10.0)
- [CVE-2004-1147](https://insights.sbomify.com/CVE-2004-1147/): Command injection in n/a (critical 10.0)
- [CVE-2020-22452](https://insights.sbomify.com/CVE-2020-22452/): phpmyadmin contains SQL Injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-5368 and fix it if it is affected.

What it is: CVE-2012-5368 is a medium-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 25 Oct 2012. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2012-5368 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 3.5; fixed in 3.5.3
- phpmyadmin/phpmyadmin (Packagist): affected from 3.5; fixed in 3.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-5368/ (Markdown: https://insights.sbomify.com/CVE-2012-5368/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-5368
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-5368
- OSV: https://osv.dev/vulnerability/CVE-2012-5368

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-5368/
Summaries are generated and may contain mistakes; the official description above is the record.
