# CVE-2012-5370: JRuby denial of service via Hash Collision

> Attackers can cause denial of service via CPU exhaustion by triggering predictable hash collisions in JRuby applications.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Nov 2012
- **Updated:** 6 Aug 2024
- **Also known as:** CVE-2011-5370, DEBIAN-CVE-2012-5370, GHSA-fmmq-j7pq-f85c, MINI-gf2f-69g9-8477, MINI-j7hx-xm35-g2qx

## What is CVE-2012-5370?

CVE-2012-5370 is a medium-severity denial of service vulnerability in n/a, published on 28 Nov 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

JRuby computes hash values without properly restricting the ability to trigger hash collisions predictably, which allows context-dependent attackers to cause a denial of service (CPU consumption) via crafted input to an application that maintains a hash table, as demonstrated by a universal multicollision attack against the MurmurHash2 algorithm, a different vulnerability than CVE-2011-4838.

Weakness: CWE-310

## Which versions are affected by CVE-2012-5370?

2 open source packages ship an affected version, including org.jruby:jruby-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jruby:jruby-parent` | Maven | All versions | 1.7.1 |
| `org.jruby:jruby-parent` | Maven | All versions | 1.7.1 |

Products: Jruby Jruby.

## How do I fix CVE-2012-5370?

Upgrade org.jruby:jruby-parent to 1.7.1 or later.

## Is CVE-2012-5370 being exploited?

There is no known exploitation of CVE-2012-5370 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-46551](https://insights.sbomify.com/CVE-2025-46551/): JRuby-OpenSSL has hostname verification disabled by default (medium 5.7)
- [CVE-2011-4838](https://insights.sbomify.com/CVE-2011-4838/): Denial of service in n/a (medium 5.0)
- [CVE-2010-1330](https://insights.sbomify.com/CVE-2010-1330/): Cross-site Scripting in in JRuby (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-5370 and fix it if it is affected.

What it is: CVE-2012-5370 is a medium-severity denial of service vulnerability in n/a, published on 28 Nov 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-5370 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jruby:jruby-parent (Maven): affected all versions; fixed in 1.7.1
- org.jruby:jruby-parent (Maven): affected all versions; fixed in 1.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-5370/ (Markdown: https://insights.sbomify.com/CVE-2012-5370/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-5370
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-5370
- OSV: https://osv.dev/vulnerability/CVE-2012-5370

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-5370/
Summaries are generated and may contain mistakes; the official description above is the record.
