CVE-2012-5485 Plone Code Injection vulnerability

Medium 6.8 Published Updated

Remote attackers can execute arbitrary Python code via the Plone admin interface, requiring high privileges.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2012-5485?

CVE-2012-5485 is a medium-severity code injection vulnerability in Plone Plone, published on 30 Sep 2014. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

registerConfiglet.py in Plone before 4.2.3 and 4.3 before beta 1 allows remote attackers to execute Python code via unspecified vectors, related to the admin interface.

Weakness: CWE-94

Which versions are affected by CVE-2012-5485?

5 open source packages ship an affected version, including plone and Plone. It affects 1 product.

PackageAffectedFixed in
plone PyPIAll versions4.2.3, 4.3b1
plone PyPIAll versions4.2.3
plone PyPIFrom 4.3a14.3b1
Plone PyPIAll versions4.2.3
Plone PyPIFrom 4.3a14.3b1

Products include Plone Plone.

How do I fix CVE-2012-5485?

Upgrade plone to a fixed version for your release line: 4.2.3 or 4.3b1.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2012-5485 being exploited?

There is no known exploitation of CVE-2012-5485 in the wild and no public exploit code.

All Plone Plone vulnerabilities

Sources

Also known as GHSA-7hxc-mwx7-5hmc, PYSEC-2014-27.

Is CVE-2012-5485 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free