CVE-2012-5488 Plone Code Injection vulnerability

Medium 5.0 Published Updated

Remote attackers can execute arbitrary Python code in Plone via crafted URLs, requiring an upgrade to secure the CMS.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2012-5488?

CVE-2012-5488 is a medium-severity code injection vulnerability in Plone Plone, published on 30 Sep 2014. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

python_scripts.py in Plone before 4.2.3 and 4.3 before beta 1 allows remote attackers to execute Python code via a crafted URL, related to createObject.

Weakness: CWE-94

Which versions are affected by CVE-2012-5488?

5 open source packages ship an affected version, including plone and Plone. It affects 1 product.

PackageAffectedFixed in
plone PyPIAll versions4.2.3, 4.3b1
plone PyPIAll versions4.2.3
plone PyPIFrom 4.3a04.3b1
Plone PyPIAll versions4.2.3
Plone PyPIFrom 4.3a04.3b1

Products include Plone Plone.

How do I fix CVE-2012-5488?

Upgrade plone to a fixed version for your release line: 4.2.3 or 4.3b1.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2012-5488 being exploited?

There is no known exploitation of CVE-2012-5488 in the wild and no public exploit code.

All Plone Plone vulnerabilities

Sources

Also known as GHSA-cxw7-85xm-3xrc, PYSEC-2014-30.

Is CVE-2012-5488 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free