# CVE-2012-5489: Plone and Zope2 vulnerable to unauthorized access to restricted attributes

> Authenticated users can bypass restrictions to access protected attributes in Zope and Plone applications.

- **Severity:** Medium 6.5 (`AV:N/AC:L/Au:S/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Sep 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-879r-7f3w-8jj3, PYSEC-2014-31, PYSEC-2014-74

## What is CVE-2012-5489?

CVE-2012-5489 is a medium-severity missing authorization vulnerability in Plone Plone, published on 30 Sep 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The App.Undo.UndoSupport.get_request_var_or_attr function in Zope before 2.12.21 and 3.13.x before 2.13.11, as used in Plone before 4.2.3 and 4.3 before beta 1, allows remote authenticated users to gain access to restricted attributes via unspecified vectors.

Weakness: CWE-264

## Which versions are affected by CVE-2012-5489?

10 open source packages ship an affected version, including plone, Plone and Zope2. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone` | PyPI | All versions | 4.2.3, 4.3b1 |
| `plone` | PyPI | From 3.2.2 | 4.2.3 |
| `plone` | PyPI | From 4.3a1 | 4.3b1 |
| `Plone` | PyPI | From 3.2.2 | 4.2.3 |
| `Plone` | PyPI | From 4.3a1 | 4.3b1 |
| `Zope2` | PyPI | All versions | 2.12.21 |
| `Zope2` | PyPI | From 2.13.0 | 2.13.11 |
| `zope2` | PyPI | All versions | 2.12.21, 2.13.11 |
| `zope2` | PyPI | All versions | 2.12.21 |
| `zope2` | PyPI | From 2.13.0 | 2.13.11 |

Products: Plone Plone, Zope Zope.

## How do I fix CVE-2012-5489?

Upgrade plone to a fixed version for your release line: 4.2.3 or 4.3b1.

## Is CVE-2012-5489 being exploited?

There is no known exploitation of CVE-2012-5489 in the wild and no public exploit code.

## Other vulnerabilities in Plone Plone

- [CVE-2021-33509](https://insights.sbomify.com/CVE-2021-33509/): Incorrect Permission Assignment for Critical Resource in Plone (critical 9.9)
- [CVE-2020-35190](https://insights.sbomify.com/CVE-2020-35190/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-7941](https://insights.sbomify.com/CVE-2020-7941/): Plone Unauthenticated Write Vulnerability (critical 9.8)
- [CVE-2011-3587](https://insights.sbomify.com/CVE-2011-3587/): Zope Command Execution Vulnerability (critical 9.3)
- [CVE-2021-33926](https://insights.sbomify.com/CVE-2021-33926/): Server-Side Request Forgery in Plone CMS (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-5489 and fix it if it is affected.

What it is: CVE-2012-5489 is a medium-severity missing authorization vulnerability in Plone Plone, published on 30 Sep 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-5489 in the wild and no public exploit code.

Affected packages and fixed versions:
- plone (PyPI): affected all versions; fixed in 4.2.3, 4.3b1
- plone (PyPI): affected from 3.2.2; fixed in 4.2.3
- plone (PyPI): affected from 4.3a1; fixed in 4.3b1
- Plone (PyPI): affected from 3.2.2; fixed in 4.2.3
- Plone (PyPI): affected from 4.3a1; fixed in 4.3b1
- Zope2 (PyPI): affected all versions; fixed in 2.12.21
- Zope2 (PyPI): affected from 2.13.0; fixed in 2.13.11
- zope2 (PyPI): affected all versions; fixed in 2.12.21, 2.13.11
- zope2 (PyPI): affected all versions; fixed in 2.12.21
- zope2 (PyPI): affected from 2.13.0; fixed in 2.13.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-5489/ (Markdown: https://insights.sbomify.com/CVE-2012-5489/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-5489
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-5489
- OSV: https://osv.dev/vulnerability/CVE-2012-5489

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-5489/
Summaries are generated and may contain mistakes; the official description above is the record.
