CVE-2012-5499 Plone is vulnerable to denial of service

Medium 5.0 Published Updated

Remote attackers can cause denial of service via memory consumption in Plone's python_scripts.py module.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2012-5499?

CVE-2012-5499 is a medium-severity denial of service vulnerability in Plone Plone, published on 30 Sep 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

python_scripts.py in Plone before 4.2.3 and 4.3 before beta 1 allows remote attackers to cause a denial of service (memory consumption) via a large value, related to formatColumns.

Weakness: CWE-399

Which versions are affected by CVE-2012-5499?

5 open source packages ship an affected version, including plone and Plone. It affects 1 product.

PackageAffectedFixed in
plone PyPIAll versions4.2.3, 4.3b1
plone PyPIFrom 4.04.2.3
plone PyPIFrom 4.3a14.3b1
Plone PyPIFrom 4.04.2.3
Plone PyPIFrom 4.3a14.3b1

Products include Plone Plone.

How do I fix CVE-2012-5499?

Upgrade plone to a fixed version for your release line: 4.2.3 or 4.3b1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2012-5499 being exploited?

There is no known exploitation of CVE-2012-5499 in the wild and no public exploit code.

All Plone Plone vulnerabilities

Sources

Also known as GHSA-wrf2-2rch-cmr9, PYSEC-2014-41.

Is CVE-2012-5499 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free