CVE-2012-5502 Plone Cross-site scripting Vulnerability

Low 3.5 Published Updated

Authenticated users with edit permissions can inject arbitrary scripts into Plone, potentially compromising other users' sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2012-5502?

CVE-2012-5502 is a low-severity cross-site scripting vulnerability in Plone Plone, published on 30 Sep 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in safe_html.py in Plone before 4.2.3 and 4.3 before beta 1 allows remote authenticated users with permissions to edit content to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79

Which versions are affected by CVE-2012-5502?

5 open source packages ship an affected version, including plone and Plone. It affects 1 product.

PackageAffectedFixed in
plone PyPIAll versions4.2.3, 4.3b1
plone PyPIAll versions4.2.3
plone PyPIFrom 4.3a04.3b1
Plone PyPIAll versions4.2.3
Plone PyPIFrom 4.3a04.3b1

Products include Plone Plone.

How do I fix CVE-2012-5502?

Upgrade plone to a fixed version for your release line: 4.2.3 or 4.3b1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2012-5502 being exploited?

There is no known exploitation of CVE-2012-5502 in the wild and no public exploit code.

All Plone Plone vulnerabilities

Sources

Also known as GHSA-hr59-35cr-qf43, PYSEC-2014-44.

Is CVE-2012-5502 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free