CVE-2012-5507 Plone and Zope2 affected by Race Condition
Remote attackers can obtain passwords via timing discrepancies in password validation within the Zope web framework.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2012-5507?
CVE-2012-5507 is a medium-severity vulnerability in Plone Plone, published on 30 Sep 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
AccessControl/AuthEncoding.py in Zope before 2.13.19, as used in Plone before 4.2.3 and 4.3 before beta 1, allows remote attackers to obtain passwords via vectors involving timing discrepancies in password validation.
Weakness: CWE-362
Which versions are affected by CVE-2012-5507?
8 open source packages ship an affected version, including plone, Plone and Zope2. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
plone PyPI | All versions | 4.2.3, 4.3b1 |
plone PyPI | From 3.2.2 | 4.2.3 |
plone PyPI | From 4.3a1 | 4.3b1 |
Plone PyPI | From 3.2.2 | 4.2.3 |
Plone PyPI | From 4.3a1 | 4.3b1 |
Zope2 PyPI | All versions | 2.13.19 |
2 more packages
zope2 PyPI | All versions | 2.13.19 |
zope2 PyPI | All versions | 2.13.19 |
Products include Plone Plone, Zope Zope.
How do I fix CVE-2012-5507?
Upgrade plone to a fixed version for your release line: 4.2.3 or 4.3b1.
Is CVE-2012-5507 being exploited?
There is no known exploitation of CVE-2012-5507 in the wild and no public exploit code.
Other vulnerabilities in Plone Plone
Sources
Also known as GHSA-3qpr-7rmg-73v8, PYSEC-2014-49, PYSEC-2014-75.