# CVE-2012-5508: Exposure of Sensitive Information in Plone

> Remote attackers can derive PRNG state from error pages to compromise password resets in Plone.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Nov 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-wprr-mc54-c62q, PYSEC-2014-50

## What is CVE-2012-5508?

CVE-2012-5508 is a medium-severity vulnerability in Plone Plone, published on 3 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The error pages in Plone before 4.2.3 and 4.3 before beta 1 allow remote attackers to obtain random numbers and derive the PRNG state for password resets via unspecified vectors.  NOTE: this identifier was SPLIT per ADT2 due to different vulnerability types. CVE-2012-6661 was assigned for the PRNG reseeding issue in Zope.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2012-5508?

5 open source packages ship an affected version, including plone and Plone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone` | PyPI | All versions | 4.2.3, 4.3b1 |
| `plone` | PyPI | All versions | 4.2.3 |
| `plone` | PyPI | From 4.3a0 | 4.3b1 |
| `Plone` | PyPI | All versions | 4.2.3 |
| `Plone` | PyPI | From 4.3a0 | 4.3b1 |

Products: Plone Plone.

## How do I fix CVE-2012-5508?

Upgrade plone to a fixed version for your release line: 4.2.3 or 4.3b1.

## Is CVE-2012-5508 being exploited?

There is no known exploitation of CVE-2012-5508 in the wild and no public exploit code.

## Other vulnerabilities in Plone Plone

- [CVE-2021-33509](https://insights.sbomify.com/CVE-2021-33509/): Incorrect Permission Assignment for Critical Resource in Plone (critical 9.9)
- [CVE-2020-35190](https://insights.sbomify.com/CVE-2020-35190/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-7941](https://insights.sbomify.com/CVE-2020-7941/): Plone Unauthenticated Write Vulnerability (critical 9.8)
- [CVE-2011-3587](https://insights.sbomify.com/CVE-2011-3587/): Zope Command Execution Vulnerability (critical 9.3)
- [CVE-2021-33926](https://insights.sbomify.com/CVE-2021-33926/): Server-Side Request Forgery in Plone CMS (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-5508 and fix it if it is affected.

What it is: CVE-2012-5508 is a medium-severity vulnerability in Plone Plone, published on 3 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-5508 in the wild and no public exploit code.

Affected packages and fixed versions:
- plone (PyPI): affected all versions; fixed in 4.2.3, 4.3b1
- plone (PyPI): affected all versions; fixed in 4.2.3
- plone (PyPI): affected from 4.3a0; fixed in 4.3b1
- Plone (PyPI): affected all versions; fixed in 4.2.3
- Plone (PyPI): affected from 4.3a0; fixed in 4.3b1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-5508/ (Markdown: https://insights.sbomify.com/CVE-2012-5508/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-5508
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-5508
- OSV: https://osv.dev/vulnerability/CVE-2012-5508

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-5508/
Summaries are generated and may contain mistakes; the official description above is the record.
