# CVE-2012-5575: Inadequate Encryption Strength in Apache CXF

> Remote attackers can force Apache CXF to use weak cryptographic algorithms, enabling easier decryption of communications and bypassing security policies.

- **Severity:** Medium 6.4 (`AV:N/AC:L/Au:N/C:P/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-7v5v-9v8r-w864, RHSA-2013:0873, RHSA-2013:0874

## What is CVE-2012-5575?

CVE-2012-5575 is a medium-severity vulnerability in Apache Cxf, published on 19 Aug 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache CXF 2.5.x before 2.5.10, 2.6.x before CXF 2.6.7, and 2.7.x before CXF 2.7.4 does not verify that a specified cryptographic algorithm is allowed by the WS-SecurityPolicy AlgorithmSuite definition before decrypting, which allows remote attackers to force CXF to use weaker cryptographic algorithms than intended and makes it easier to decrypt communications, aka "XML Encryption backwards compatibility attack."

Weakness: CWE-310

## Which versions are affected by CVE-2012-5575?

6 open source packages ship an affected version, including org.apache.cxf:cxf-rt-transports-http. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.cxf:cxf-rt-transports-http` | Maven | From 2.5.0 | 2.5.10 |
| `org.apache.cxf:cxf-rt-transports-http` | Maven | From 2.5.0 | 2.5.10 |
| `org.apache.cxf:cxf-rt-transports-http` | Maven | From 2.6.0 | 2.6.7 |
| `org.apache.cxf:cxf-rt-transports-http` | Maven | From 2.6.0 | 2.6.7 |
| `org.apache.cxf:cxf-rt-transports-http` | Maven | From 2.7.0 | 2.7.4 |
| `org.apache.cxf:cxf-rt-transports-http` | Maven | From 2.7.0 | 2.7.4 |
| `apache-cxf` | Red Hat:jboss_enterprise_application_platform:5::el4 | All versions | 0:2.2.12-12.patch_07.ep5.el4 |
| `jbossws` | Red Hat:jboss_enterprise_application_platform:5::el4 | All versions | 0:3.1.2-14.SP15_patch_02.ep5.el4 |
| `wss4j` | Red Hat:jboss_enterprise_application_platform:5::el4 | All versions | 0:1.5.12-6_patch_03.ep5.el4 |
| `apache-cxf` | Red Hat:jboss_enterprise_application_platform:5::el5 | All versions | 0:2.2.12-12.patch_07.ep5.el5 |
| `jbossws` | Red Hat:jboss_enterprise_application_platform:5::el5 | All versions | 0:3.1.2-14.SP15_patch_02.ep5.el5 |
| `wss4j` | Red Hat:jboss_enterprise_application_platform:5::el5 | All versions | 0:1.5.12-6_patch_03.ep5.el5 |
| `apache-cxf` | Red Hat:jboss_enterprise_application_platform:5::el6 | All versions | 0:2.2.12-12.patch_07.ep5.el6 |
| `jbossws` | Red Hat:jboss_enterprise_application_platform:5::el6 | All versions | 0:3.1.2-14.SP15_patch_02.ep5.el6 |
| `wss4j` | Red Hat:jboss_enterprise_application_platform:5::el6 | All versions | 0:1.5.12-6_patch_03.ep5.el6 |
| `apache-cxf` | Red Hat:jboss_enterprise_web_platform:5::el5 | All versions | 0:2.2.12-12.patch_07.ep5.el5 |
| `jbossws` | Red Hat:jboss_enterprise_web_platform:5::el5 | All versions | 0:3.1.2-14.SP15_patch_02.ep5.el5 |
| `wss4j` | Red Hat:jboss_enterprise_web_platform:5::el5 | All versions | 0:1.5.12-6_patch_03.ep5.el5 |
| `apache-cxf` | Red Hat:jboss_enterprise_web_platform:5::el6 | All versions | 0:2.2.12-12.patch_07.ep5.el6 |
| `jbossws` | Red Hat:jboss_enterprise_web_platform:5::el6 | All versions | 0:3.1.2-14.SP15_patch_02.ep5.el6 |
| `wss4j` | Red Hat:jboss_enterprise_web_platform:5::el6 | All versions | 0:1.5.12-6_patch_03.ep5.el6 |

Products: Apache Cxf, Redhat Jboss Enterprise Application Platform, Redhat Jboss Enterprise Portal Platform, Redhat Jboss Enterprise Soa Platform, Redhat Jboss Enterprise Web Platform, Redhat Jboss Fuse Esb Enterprise.

## How do I fix CVE-2012-5575?

Upgrade org.apache.cxf:cxf-rt-transports-http to a fixed version for your release line: 2.5.10, 2.6.7 or 2.7.4.

## Is CVE-2012-5575 being exploited?

There is no known exploitation of CVE-2012-5575 in the wild and no public exploit code.

Public exploit code:

- https://github.com/tafamace/CVE-2012-5575 (github_poc): https://github.com/tafamace/CVE-2012-5575

## Other vulnerabilities in Apache Cxf

- [CVE-2012-2379](https://insights.sbomify.com/CVE-2012-2379/): XML Signature/Encryption Not Validated in Apache CXF (critical 10.0)
- [CVE-2026-66909](https://insights.sbomify.com/CVE-2026-66909/): Apache CXF: Unsafe deserialization of inbound JMS ObjectMessage (critical 9.8)
- [CVE-2026-68079](https://insights.sbomify.com/CVE-2026-68079/): Apache CXF: DefaultEncryptingCodeDataProvider allows unlimited authorization code replay (critical 9.8)
- [CVE-2026-50628](https://insights.sbomify.com/CVE-2026-50628/): Apache CXF: OAuth2: Inverted IP Binding Check Defeats Security Control (critical 9.8)
- [CVE-2025-48913](https://insights.sbomify.com/CVE-2025-48913/): Apache CXF: Untrusted JMS configuration can lead to RCE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-5575 and fix it if it is affected.

What it is: CVE-2012-5575 is a medium-severity vulnerability in Apache Cxf, published on 19 Aug 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-5575 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.cxf:cxf-rt-transports-http (Maven): affected from 2.5.0; fixed in 2.5.10
- org.apache.cxf:cxf-rt-transports-http (Maven): affected from 2.5.0; fixed in 2.5.10
- org.apache.cxf:cxf-rt-transports-http (Maven): affected from 2.6.0; fixed in 2.6.7
- org.apache.cxf:cxf-rt-transports-http (Maven): affected from 2.6.0; fixed in 2.6.7
- org.apache.cxf:cxf-rt-transports-http (Maven): affected from 2.7.0; fixed in 2.7.4
- org.apache.cxf:cxf-rt-transports-http (Maven): affected from 2.7.0; fixed in 2.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-5575/ (Markdown: https://insights.sbomify.com/CVE-2012-5575/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-5575
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-5575
- OSV: https://osv.dev/vulnerability/CVE-2012-5575

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-5575/
Summaries are generated and may contain mistakes; the official description above is the record.
