# CVE-2012-5604: ldap_fluff authentication bypass

> Remote attackers can bypass authentication in applications using the ldap_fluff gem with Active Directory, potentially gaining unauthorized access.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Mar 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-9whh-582r-589h

## What is CVE-2012-5604?

CVE-2012-5604 is a medium-severity authentication bypass vulnerability in n/a, published on 1 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The ldap_fluff gem for Ruby, as used in Red Hat CloudForms 1.1, when using Active Directory for authentication, allows remote attackers to bypass authentication via unspecified vectors.

Weakness: CWE-264

## Which versions are affected by CVE-2012-5604?

2 open source packages ship an affected version, including ldap_fluff. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ldap_fluff` | RubyGems | All versions | 0.4.0 |
| `ldap_fluff` | RubyGems | All versions | 0.4.0 |

Products: Redhat Cloudforms.

## How do I fix CVE-2012-5604?

Upgrade ldap_fluff to 0.4.0 or later.

## Is CVE-2012-5604 being exploited?

There is no known exploitation of CVE-2012-5604 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-14325](https://insights.sbomify.com/CVE-2020-14325/): Auth bypass in CloudForms (critical 9.1)
- [CVE-2014-0197](https://insights.sbomify.com/CVE-2014-0197/): Cross-site request forgery in CFME (high 8.8)
- [CVE-2016-5402](https://insights.sbomify.com/CVE-2016-5402/): Code injection in cfme (high 8.8)
- [CVE-2016-7071](https://insights.sbomify.com/CVE-2016-7071/): Missing authorization in CFME (high 8.8)
- [CVE-2017-7530](https://insights.sbomify.com/CVE-2017-7530/): Missing authorization in cfme (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-5604 and fix it if it is affected.

What it is: CVE-2012-5604 is a medium-severity authentication bypass vulnerability in n/a, published on 1 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-5604 in the wild and no public exploit code.

Affected packages and fixed versions:
- ldap_fluff (RubyGems): affected all versions; fixed in 0.4.0
- ldap_fluff (RubyGems): affected all versions; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-5604/ (Markdown: https://insights.sbomify.com/CVE-2012-5604/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-5604
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-5604
- OSV: https://osv.dev/vulnerability/CVE-2012-5604

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-5604/
Summaries are generated and may contain mistakes; the official description above is the record.
