# CVE-2012-5633: Improper Authentication in Apache CXF

> Remote attackers can bypass WS-Security authentication in Apache CXF SOAP services via HTTP GET requests, gaining unauthorized access to protected resources.

- **Severity:** Medium 5.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-xf9f-32gh-h2w4

## What is CVE-2012-5633?

CVE-2012-5633 is a medium-severity authentication bypass vulnerability in Apache Cxf, published on 12 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The URIMappingInterceptor in Apache CXF before 2.5.8, 2.6.x before 2.6.5, and 2.7.x before 2.7.2, when using the WSS4JInInterceptor, bypasses WS-Security processing, which allows remote attackers to obtain access to SOAP services via an HTTP GET request.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2012-5633?

6 open source packages ship an affected version, including org.apache.cxf:cxf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.cxf:cxf` | Maven | All versions | 2.5.8 |
| `org.apache.cxf:cxf` | Maven | All versions | 2.5.8 |
| `org.apache.cxf:cxf` | Maven | From 2.6.0 | 2.6.5 |
| `org.apache.cxf:cxf` | Maven | From 2.6.0 | 2.6.5 |
| `org.apache.cxf:cxf` | Maven | From 2.7.0 | 2.7.2 |
| `org.apache.cxf:cxf` | Maven | From 2.7.0 | 2.7.2 |

Products: Apache Cxf.

## How do I fix CVE-2012-5633?

Upgrade org.apache.cxf:cxf to a fixed version for your release line: 2.5.8, 2.6.5 or 2.7.2.

## Is CVE-2012-5633 being exploited?

There is no known exploitation of CVE-2012-5633 in the wild and no public exploit code.

## Other vulnerabilities in Apache Cxf

- [CVE-2012-2379](https://insights.sbomify.com/CVE-2012-2379/): XML Signature/Encryption Not Validated in Apache CXF (critical 10.0)
- [CVE-2026-66909](https://insights.sbomify.com/CVE-2026-66909/): Apache CXF: Unsafe deserialization of inbound JMS ObjectMessage (critical 9.8)
- [CVE-2026-68079](https://insights.sbomify.com/CVE-2026-68079/): Apache CXF: DefaultEncryptingCodeDataProvider allows unlimited authorization code replay (critical 9.8)
- [CVE-2026-50628](https://insights.sbomify.com/CVE-2026-50628/): Apache CXF: OAuth2: Inverted IP Binding Check Defeats Security Control (critical 9.8)
- [CVE-2025-48913](https://insights.sbomify.com/CVE-2025-48913/): Apache CXF: Untrusted JMS configuration can lead to RCE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-5633 and fix it if it is affected.

What it is: CVE-2012-5633 is a medium-severity authentication bypass vulnerability in Apache Cxf, published on 12 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-5633 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.cxf:cxf (Maven): affected all versions; fixed in 2.5.8
- org.apache.cxf:cxf (Maven): affected all versions; fixed in 2.5.8
- org.apache.cxf:cxf (Maven): affected from 2.6.0; fixed in 2.6.5
- org.apache.cxf:cxf (Maven): affected from 2.6.0; fixed in 2.6.5
- org.apache.cxf:cxf (Maven): affected from 2.7.0; fixed in 2.7.2
- org.apache.cxf:cxf (Maven): affected from 2.7.0; fixed in 2.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-5633/ (Markdown: https://insights.sbomify.com/CVE-2012-5633/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-5633
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-5633
- OSV: https://osv.dev/vulnerability/CVE-2012-5633

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-5633/
Summaries are generated and may contain mistakes; the official description above is the record.
