CVE-2012-5657 Zend Framework XXE Vulnerability

Medium 5.0 Published Updated

Remote attackers can exploit an XML External Entity vulnerability in Zend Framework to read arbitrary files, access intranet servers, or cause denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2012-5657?

CVE-2012-5657 is a medium-severity vulnerability in n/a, published on 2 May 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The (1) Zend_Feed_Rss and (2) Zend_Feed_Atom classes in Zend_Feed in Zend Framework 1.11.x before 1.11.15 and 1.12.x before 1.12.1 allow remote attackers to read arbitrary files, send HTTP requests to intranet servers, and possibly cause a denial of service (CPU and memory consumption) via an XML External Entity (XXE) attack.

Weakness: CWE-200

Which versions are affected by CVE-2012-5657?

4 open source packages ship an affected version, including zendframework/zendframework1. It affects 1 product.

PackageAffectedFixed in
zendframework/zendframework1 PackagistAll versions1.11.15
zendframework/zendframework1 PackagistAll versions1.11.15
zendframework/zendframework1 PackagistFrom 1.12.0-rc11.12.1
zendframework/zendframework1 PackagistFrom 1.12.0-rc11.12.1

Products include Zend Zend Framework.

How do I fix CVE-2012-5657?

Upgrade zendframework/zendframework1 to a fixed version for your release line: 1.11.15 or 1.12.1.

Is CVE-2012-5657 being exploited?

There is no known exploitation of CVE-2012-5657 in the wild and no public exploit code.

Sources

Also known as DSA-2602-1, GHSA-9m5v-vq4f-mrvf, UBUNTU-CVE-2012-5657.

Is CVE-2012-5657 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free