CVE-2012-5887 Improper Authentication in Apache Tomcat
Remote attackers can bypass access restrictions in Apache Tomcat by sniffing network traffic and exploiting stale nonce values in HTTP Digest Authentication.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2012-5887?
CVE-2012-5887 is a medium-severity authentication bypass vulnerability in Apache Tomcat, published on 17 Nov 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The HTTP Digest Access Authentication implementation in Apache Tomcat 5.5.x before 5.5.36, 6.x before 6.0.36, and 7.x before 7.0.30 does not properly check for stale nonce values in conjunction with enforcement of proper credentials, which makes it easier for remote attackers to bypass intended access restrictions by sniffing the network for valid requests.
Weakness: CWE-287
Which versions are affected by CVE-2012-5887?
6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.36 |
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.36 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.36 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.36 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.30 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.30 |
Products include Apache Tomcat.
How do I fix CVE-2012-5887?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 5.5.36, 6.0.36 or 7.0.30.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2012-5887 being exploited?
There is no known exploitation of CVE-2012-5887 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-28cq-6rmx-pjq4.