# CVE-2012-5890: Front End User Registration (sr_feuser_register) extension for TYPO3 allows remote attackers to obtain user names, passwords

> Remote attackers can obtain user names and passwords via the edit perspective or autologin feature in the Front End User Registration extension.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Nov 2012
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-m646-h2pw-56h4

## What is CVE-2012-5890?

CVE-2012-5890 is a medium-severity vulnerability in n/a, published on 17 Nov 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Front End User Registration (sr_feuser_register) extension before 2.6.2 for TYPO3 allows remote attackers to obtain user names and passwords via the (1) edit perspective or (2) autologin feature.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2012-5890?

2 open source packages ship an affected version, including sjbr/sr-feuser-register. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sjbr/sr-feuser-register` | Packagist | All versions | 2.6.2 |
| `sjbr/sr-feuser-register` | Packagist | All versions | 2.6.2 |

Products: Stanislas Rolland Sr Feuser Register.

## How do I fix CVE-2012-5890?

Upgrade sjbr/sr-feuser-register to 2.6.2 or later.

## Is CVE-2012-5890 being exploited?

There is no known exploitation of CVE-2012-5890 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2009-1264](https://insights.sbomify.com/CVE-2009-1264/): Frontend User Registration extension for TYPO3 does not properly verify access rights (medium 4.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-5890 and fix it if it is affected.

What it is: CVE-2012-5890 is a medium-severity vulnerability in n/a, published on 17 Nov 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-5890 in the wild and no public exploit code.

Affected packages and fixed versions:
- sjbr/sr-feuser-register (Packagist): affected all versions; fixed in 2.6.2
- sjbr/sr-feuser-register (Packagist): affected all versions; fixed in 2.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-5890/ (Markdown: https://insights.sbomify.com/CVE-2012-5890/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-5890
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-5890
- OSV: https://osv.dev/vulnerability/CVE-2012-5890

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-5890/
Summaries are generated and may contain mistakes; the official description above is the record.
