{"answers":{"affected":"8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-6099 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 2.1.10, 2.2.7, 2.3.4 or 2.4.1.","what":"CVE-2012-6099 is a medium-severity path traversal vulnerability in Moodle Moodle, published on 27 Jan 2013. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2012-6099 and fix it if it is affected.\n\nWhat it is: CVE-2012-6099 is a medium-severity path traversal vulnerability in Moodle Moodle, published on 27 Jan 2013. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2012-6099 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 2.1; fixed in 2.1.10\n- moodle/moodle (Packagist): affected from 2.1; fixed in 2.1.10\n- moodle/moodle (Packagist): affected from 2.2; fixed in 2.2.7\n- moodle/moodle (Packagist): affected from 2.2; fixed in 2.2.7\n- moodle/moodle (Packagist): affected from 2.3; fixed in 2.3.4\n- moodle/moodle (Packagist): affected from 2.3; fixed in 2.3.4\n- moodle/moodle (Packagist): affected from 2.4; fixed in 2.4.1\n- moodle/moodle (Packagist): affected from 2.4; fixed in 2.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-6099/ (Markdown: https://insights.sbomify.com/CVE-2012-6099/index.md)","id":"CVE-2012-6099","markdown":"https://insights.sbomify.com/CVE-2012-6099/index.md","name":"CVE-2012-6099","record":{"aliases":["GHSA-cr78-rphw-w73p"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"low_privilege","summary":"Authenticated users can read arbitrary files via path traversal in the Moodle backup converter, requiring an upgrade to secure the system.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":4,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:S/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The moodle1 backup converter in backup/converter/moodle1/lib.php in Moodle 2.1.x before 2.1.10, 2.2.x before 2.2.7, 2.3.x before 2.3.4, and 2.4.x before 2.4.1 does not properly validate pathnames, which allows remote authenticated users to read arbitrary files by leveraging the backup-restoration feature.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle Arbitrary File Read via Backup Functionality","id":"CVE-2012-6099","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"path_traversal","year":"2012"},"n_packages":8,"n_references":3,"next":{"headline":"Missing authorization in n/a","id":"CVE-2012-6100"},"packages":[{"ecosystem":"Packagist","fixed":["2.1.10"],"introduced":["2.1"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-cr78-rphw-w73p"},{"ecosystem":"Packagist","fixed":["2.1.10"],"introduced":["2.1"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-cr78-rphw-w73p"},{"ecosystem":"Packagist","fixed":["2.2.7"],"introduced":["2.2"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-cr78-rphw-w73p"},{"ecosystem":"Packagist","fixed":["2.2.7"],"introduced":["2.2"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-cr78-rphw-w73p"},{"ecosystem":"Packagist","fixed":["2.3.4"],"introduced":["2.3"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-cr78-rphw-w73p"},{"ecosystem":"Packagist","fixed":["2.3.4"],"introduced":["2.3"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-cr78-rphw-w73p"},{"ecosystem":"Packagist","fixed":["2.4.1"],"introduced":["2.4"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-cr78-rphw-w73p"},{"ecosystem":"Packagist","fixed":["2.4.1"],"introduced":["2.4"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-cr78-rphw-w73p"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2012-6098"},"products":["n/a"],"published":"2013-01-27","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Authenticated users can read arbitrary files via path traversal in the Moodle backup converter, requiring an upgrade to secure the system.","url":"https://insights.sbomify.com/CVE-2012-6099/"}