# CVE-2012-6099: Moodle Arbitrary File Read via Backup Functionality

> Authenticated users can read arbitrary files via path traversal in the Moodle backup converter, requiring an upgrade to secure the system.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2013
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-cr78-rphw-w73p

## What is CVE-2012-6099?

CVE-2012-6099 is a medium-severity path traversal vulnerability in Moodle Moodle, published on 27 Jan 2013. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The moodle1 backup converter in backup/converter/moodle1/lib.php in Moodle 2.1.x before 2.1.10, 2.2.x before 2.2.7, 2.3.x before 2.3.4, and 2.4.x before 2.4.1 does not properly validate pathnames, which allows remote authenticated users to read arbitrary files by leveraging the backup-restoration feature.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2012-6099?

8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 2.1 | 2.1.10 |
| `moodle/moodle` | Packagist | From 2.1 | 2.1.10 |
| `moodle/moodle` | Packagist | From 2.2 | 2.2.7 |
| `moodle/moodle` | Packagist | From 2.2 | 2.2.7 |
| `moodle/moodle` | Packagist | From 2.3 | 2.3.4 |
| `moodle/moodle` | Packagist | From 2.3 | 2.3.4 |
| `moodle/moodle` | Packagist | From 2.4 | 2.4.1 |
| `moodle/moodle` | Packagist | From 2.4 | 2.4.1 |

Products: Moodle Moodle.

## How do I fix CVE-2012-6099?

Upgrade moodle/moodle to a fixed version for your release line: 2.1.10, 2.2.7, 2.3.4 or 2.4.1.

## Is CVE-2012-6099 being exploited?

There is no known exploitation of CVE-2012-6099 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-6099 and fix it if it is affected.

What it is: CVE-2012-6099 is a medium-severity path traversal vulnerability in Moodle Moodle, published on 27 Jan 2013. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-6099 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 2.1; fixed in 2.1.10
- moodle/moodle (Packagist): affected from 2.1; fixed in 2.1.10
- moodle/moodle (Packagist): affected from 2.2; fixed in 2.2.7
- moodle/moodle (Packagist): affected from 2.2; fixed in 2.2.7
- moodle/moodle (Packagist): affected from 2.3; fixed in 2.3.4
- moodle/moodle (Packagist): affected from 2.3; fixed in 2.3.4
- moodle/moodle (Packagist): affected from 2.4; fixed in 2.4.1
- moodle/moodle (Packagist): affected from 2.4; fixed in 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-6099/ (Markdown: https://insights.sbomify.com/CVE-2012-6099/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-6099
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-6099
- OSV: https://osv.dev/vulnerability/CVE-2012-6099

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-6099/
Summaries are generated and may contain mistakes; the official description above is the record.
