CVE-2012-6109 Rack vulnerable to REDoS
Remote attackers can cause a denial of service via an infinite loop triggered by a crafted Content-Disposition header in the Rack library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2012-6109?
CVE-2012-6109 is a medium-severity denial of service vulnerability in n/a, published on 1 Mar 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
lib/rack/multipart.rb in Rack before 1.1.4, 1.2.x before 1.2.6, 1.3.x before 1.3.7, and 1.4.x before 1.4.2 uses an incorrect regular expression, which allows remote attackers to cause a denial of service (infinite loop) via a crafted Content-Disposion header.
Which versions are affected by CVE-2012-6109?
8 open source packages ship an affected version, including rack. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
rack RubyGems | All versions | 1.1.4 |
rack RubyGems | All versions | 1.1.4 |
rack RubyGems | From 1.2.0 | 1.2.6 |
rack RubyGems | From 1.2.0 | 1.2.6 |
rack RubyGems | From 1.3.0 | 1.3.7 |
rack RubyGems | From 1.3.0 | 1.3.7 |
2 more packages
rack RubyGems | From 1.4.0 | 1.4.2 |
rack RubyGems | From 1.4.0 | 1.4.2 |
Products include Rack Project Rack.
How do I fix CVE-2012-6109?
Upgrade rack to a fixed version for your release line: 1.1.4, 1.2.6, 1.3.7 or 1.4.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2012-6109 being exploited?
There is no known exploitation of CVE-2012-6109 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2018-16470 Rack vulnerable to Denial of Service
- CVE-2013-0263 Rack arbitrary code execution via timing attack
- CVE-2013-0183 Rack rubygems receiving excessively long lines triggers out-of-memory error
- CVE-2011-5036 Rack Gem Subject to Denial of Service via Hash Collisions
- CVE-2013-0184 Rack vulnerable to Denial of Service
Sources
Also known as DEBIAN-CVE-2012-6109, GHSA-h77x-m5q8-c29h, UBUNTU-CVE-2012-6109.