CVE-2012-6112 PHP Spellchecker addon for TinyMCE allows attackers to trigger arbitrary outbound HTTP requests
Remote attackers can trigger arbitrary outbound HTTP requests via crafted strings in the TinyMCE spellchecker, potentially leading to SSRF.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2012-6112?
CVE-2012-6112 is a medium-severity server-side request forgery vulnerability in Moodle Moodle, published on 27 Jan 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
classes/GoogleSpell.php in the PHP Spellchecker (aka Google Spellchecker) addon before 2.0.6.1 for TinyMCE, as used in Moodle 2.1.x before 2.1.10, 2.2.x before 2.2.7, 2.3.x before 2.3.4, and 2.4.x before 2.4.1 and other products, does not properly handle control characters, which allows remote attackers to trigger arbitrary outbound HTTP requests via a crafted string.
Weakness: CWE-264
Which versions are affected by CVE-2012-6112?
8 open source packages ship an affected version, including moodle/moodle. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.1.0 | 2.1.10 |
moodle/moodle Packagist | From 2.1.0 | 2.1.10 |
moodle/moodle Packagist | From 2.2.0 | 2.2.7 |
moodle/moodle Packagist | From 2.2.0 | 2.2.7 |
moodle/moodle Packagist | From 2.3.0 | 2.3.4 |
moodle/moodle Packagist | From 2.3.0 | 2.3.4 |
2 more packages
moodle/moodle Packagist | From 2.4.0 | 2.4.1 |
moodle/moodle Packagist | From 2.4.0 | 2.4.1 |
Products include Moodle Moodle, Tinymce Spellchecker Php.
How do I fix CVE-2012-6112?
Upgrade moodle/moodle to a fixed version for your release line: 2.1.10, 2.2.7, 2.3.4 or 2.4.1.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2012-6112 being exploited?
There is no known exploitation of CVE-2012-6112 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as DEBIAN-CVE-2012-6112, GHSA-fx5h-3786-h2w6, UBUNTU-CVE-2012-6112.