# CVE-2012-6112: PHP Spellchecker addon for TinyMCE allows attackers to trigger arbitrary outbound HTTP requests

> Remote attackers can trigger arbitrary outbound HTTP requests via crafted strings in the TinyMCE spellchecker, potentially leading to SSRF.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2012-6112, GHSA-fx5h-3786-h2w6, UBUNTU-CVE-2012-6112

## What is CVE-2012-6112?

CVE-2012-6112 is a medium-severity server-side request forgery vulnerability in Moodle Moodle, published on 27 Jan 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

classes/GoogleSpell.php in the PHP Spellchecker (aka Google Spellchecker) addon before 2.0.6.1 for TinyMCE, as used in Moodle 2.1.x before 2.1.10, 2.2.x before 2.2.7, 2.3.x before 2.3.4, and 2.4.x before 2.4.1 and other products, does not properly handle control characters, which allows remote attackers to trigger arbitrary outbound HTTP requests via a crafted string.

Weakness: CWE-264

## Which versions are affected by CVE-2012-6112?

8 open source packages ship an affected version, including moodle/moodle. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 2.1.0 | 2.1.10 |
| `moodle/moodle` | Packagist | From 2.1.0 | 2.1.10 |
| `moodle/moodle` | Packagist | From 2.2.0 | 2.2.7 |
| `moodle/moodle` | Packagist | From 2.2.0 | 2.2.7 |
| `moodle/moodle` | Packagist | From 2.3.0 | 2.3.4 |
| `moodle/moodle` | Packagist | From 2.3.0 | 2.3.4 |
| `moodle/moodle` | Packagist | From 2.4.0 | 2.4.1 |
| `moodle/moodle` | Packagist | From 2.4.0 | 2.4.1 |

Products: Moodle Moodle, Tinymce Spellchecker Php.

## How do I fix CVE-2012-6112?

Upgrade moodle/moodle to a fixed version for your release line: 2.1.10, 2.2.7, 2.3.4 or 2.4.1.

## Is CVE-2012-6112 being exploited?

There is no known exploitation of CVE-2012-6112 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-6112 and fix it if it is affected.

What it is: CVE-2012-6112 is a medium-severity server-side request forgery vulnerability in Moodle Moodle, published on 27 Jan 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-6112 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 2.1.0; fixed in 2.1.10
- moodle/moodle (Packagist): affected from 2.1.0; fixed in 2.1.10
- moodle/moodle (Packagist): affected from 2.2.0; fixed in 2.2.7
- moodle/moodle (Packagist): affected from 2.2.0; fixed in 2.2.7
- moodle/moodle (Packagist): affected from 2.3.0; fixed in 2.3.4
- moodle/moodle (Packagist): affected from 2.3.0; fixed in 2.3.4
- moodle/moodle (Packagist): affected from 2.4.0; fixed in 2.4.1
- moodle/moodle (Packagist): affected from 2.4.0; fixed in 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-6112/ (Markdown: https://insights.sbomify.com/CVE-2012-6112/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-6112
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-6112
- OSV: https://osv.dev/vulnerability/CVE-2012-6112

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-6112/
Summaries are generated and may contain mistakes; the official description above is the record.
