{"answers":{"affected":"3 open source packages ship an affected version, including roundup. It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-6133 in the wild and no public exploit code.","fix":"Upgrade roundup to 1.4.20 or later.","what":"CVE-2012-6133 is a medium-severity cross-site scripting vulnerability in Roundup, published on 30 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2012-6133 and fix it if it is affected.\n\nWhat it is: CVE-2012-6133 is a medium-severity cross-site scripting vulnerability in Roundup, published on 30 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2012-6133 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- roundup (PyPI): affected all versions; fixed in 1.4.20\n- roundup (PyPI): affected all versions; fixed in 1.4.20\n- roundup (PyPI): affected all versions; fixed in 1.4.20\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-6133/ (Markdown: https://insights.sbomify.com/CVE-2012-6133/index.md)","id":"CVE-2012-6133","markdown":"https://insights.sbomify.com/CVE-2012-6133/index.md","name":"CVE-2012-6133","record":{"aliases":["GHSA-5jq3-8437-x35p","PYSEC-2020-212"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Roundup issue tracker","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via specific parameters in the Roundup issue tracker, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"roundup","vendor":"roundup-tracker"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in Roundup before 1.4.20 allow remote attackers to inject arbitrary web script or HTML via the (1) @ok_message or (2) @error_message parameter to issue*.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Multiple cross-site scripting (XSS) vulnerabilities in Roundup","id":"CVE-2012-6133","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2012"},"n_packages":3,"n_references":5,"next":{"headline":"omniauth-oauth2 Cross-Site Request Forgery vulnerability","id":"CVE-2012-6134"},"packages":[{"ecosystem":"PyPI","fixed":["1.4.20"],"introduced":["0"],"last_affected":[],"package":"roundup","purl":null,"source":"GHSA-5jq3-8437-x35p"},{"ecosystem":"PyPI","fixed":["1.4.20"],"introduced":["0"],"last_affected":[],"package":"roundup","purl":"pkg:pypi/roundup","source":"GHSA-5jq3-8437-x35p"},{"ecosystem":"PyPI","fixed":["1.4.20"],"introduced":["0"],"last_affected":[],"package":"roundup","purl":"pkg:pypi/roundup","source":"PYSEC-2020-212"}],"prev":{"headline":"Roundup Cross-site Scripting (XSS) vulnerability","id":"CVE-2012-6132"},"products":["Roundup"],"published":"2020-01-30","related":[{"cvss_score":6.4,"headline":"Roundup xml-rpc server improper check of property permissions","id":"CVE-2008-1475","kev_date_added":null,"published":"2008-03-24"},{"cvss_score":6.1,"headline":"Roundup Cross-site Scripting Vulnerability","id":"CVE-2024-39124","kev_date_added":null,"published":"2024-07-17"},{"cvss_score":5.4,"headline":"Roundup Cross-site Scripting Vulnerability","id":"CVE-2024-39125","kev_date_added":null,"published":"2024-07-17"},{"cvss_score":5.4,"headline":"Roundup Cross-site Scripting Vulnerability","id":"CVE-2024-39126","kev_date_added":null,"published":"2024-07-17"},{"cvss_score":5,"headline":"Roundup Directory traversal vulnerability","id":"CVE-2004-1444","kev_date_added":null,"published":"2005-02-13"},{"cvss_score":4.3,"headline":"Roundup Cross-site Scripting (XSS) vulnerability","id":"CVE-2012-6130","kev_date_added":null,"published":"2014-04-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["Roundup"]},"summary":"Remote attackers can inject arbitrary web script or HTML via specific parameters in the Roundup issue tracker, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2012-6133/"}