# CVE-2012-6133: Multiple cross-site scripting (XSS) vulnerabilities in Roundup

> Remote attackers can inject arbitrary web script or HTML via specific parameters in the Roundup issue tracker, potentially compromising user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jan 2020
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-5jq3-8437-x35p, PYSEC-2020-212

## What is CVE-2012-6133?

CVE-2012-6133 is a medium-severity cross-site scripting vulnerability in Roundup, published on 30 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in Roundup before 1.4.20 allow remote attackers to inject arbitrary web script or HTML via the (1) @ok_message or (2) @error_message parameter to issue*.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2012-6133?

3 open source packages ship an affected version, including roundup. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `roundup` | PyPI | All versions | 1.4.20 |
| `roundup` | PyPI | All versions | 1.4.20 |
| `roundup` | PyPI | All versions | 1.4.20 |

Products: Roundup-Tracker Roundup.

## How do I fix CVE-2012-6133?

Upgrade roundup to 1.4.20 or later.

## Is CVE-2012-6133 being exploited?

There is no known exploitation of CVE-2012-6133 in the wild and no public exploit code.

## Other vulnerabilities in Roundup

- [CVE-2008-1475](https://insights.sbomify.com/CVE-2008-1475/): Roundup xml-rpc server improper check of property permissions (medium 6.4)
- [CVE-2024-39124](https://insights.sbomify.com/CVE-2024-39124/): Roundup Cross-site Scripting Vulnerability (medium 6.1)
- [CVE-2024-39125](https://insights.sbomify.com/CVE-2024-39125/): Roundup Cross-site Scripting Vulnerability (medium 5.4)
- [CVE-2024-39126](https://insights.sbomify.com/CVE-2024-39126/): Roundup Cross-site Scripting Vulnerability (medium 5.4)
- [CVE-2004-1444](https://insights.sbomify.com/CVE-2004-1444/): Roundup Directory traversal vulnerability (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-6133 and fix it if it is affected.

What it is: CVE-2012-6133 is a medium-severity cross-site scripting vulnerability in Roundup, published on 30 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2012-6133 in the wild and no public exploit code.

Affected packages and fixed versions:
- roundup (PyPI): affected all versions; fixed in 1.4.20
- roundup (PyPI): affected all versions; fixed in 1.4.20
- roundup (PyPI): affected all versions; fixed in 1.4.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-6133/ (Markdown: https://insights.sbomify.com/CVE-2012-6133/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-6133
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-6133
- OSV: https://osv.dev/vulnerability/CVE-2012-6133

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-6133/
Summaries are generated and may contain mistakes; the official description above is the record.
