{"answers":{"affected":"2 open source packages ship an affected version, including omniauth-oauth2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2012-6134 in the wild and no public exploit code.","fix":"Upgrade omniauth-oauth2 to 1.1.1 or later.","what":"CVE-2012-6134 is a medium-severity vulnerability in n/a, published on 9 Apr 2013. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2012-6134 and fix it if it is affected.\n\nWhat it is: CVE-2012-6134 is a medium-severity vulnerability in n/a, published on 9 Apr 2013. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2012-6134 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- omniauth-oauth2 (RubyGems): affected all versions; fixed in 1.1.1\n- omniauth-oauth2 (RubyGems): affected all versions; fixed in 1.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2012-6134/ (Markdown: https://insights.sbomify.com/CVE-2012-6134/index.md)","id":"CVE-2012-6134","markdown":"https://insights.sbomify.com/CVE-2012-6134/index.md","name":"CVE-2012-6134","record":{"aliases":["GHSA-fgmx-8h93-26fh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby OAuth2 library","requires_auth":"low_privilege","summary":"Remote attackers can hijack user authentication sessions via CSRF in the omniauth-oauth2 Ruby gem, requiring user interaction to modify session state.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"omniauth-oauth2","vendor":"omniauth-oauth2_project"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Cross-site request forgery (CSRF) vulnerability in the omniauth-oauth2 gem 1.1.1 and earlier for Ruby allows remote attackers to hijack the authentication of users for requests that modify session state.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"omniauth-oauth2 Cross-Site Request Forgery vulnerability","id":"CVE-2012-6134","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"csrf","year":"2012"},"n_packages":2,"n_references":5,"next":{"headline":"RubyGems passenger gem allows remote attackers to delete files","id":"CVE-2012-6135"},"packages":[{"ecosystem":"RubyGems","fixed":["1.1.1"],"introduced":["0"],"last_affected":[],"package":"omniauth-oauth2","purl":null,"source":"GHSA-fgmx-8h93-26fh"},{"ecosystem":"RubyGems","fixed":["1.1.1"],"introduced":["0"],"last_affected":[],"package":"omniauth-oauth2","purl":"pkg:gem/omniauth-oauth2","source":"GHSA-fgmx-8h93-26fh"}],"prev":{"headline":"Multiple cross-site scripting (XSS) vulnerabilities in Roundup","id":"CVE-2012-6133"},"products":["n/a"],"published":"2013-04-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Remote attackers can hijack user authentication sessions via CSRF in the omniauth-oauth2 Ruby gem, requiring user interaction to modify session state.","url":"https://insights.sbomify.com/CVE-2012-6134/"}