# CVE-2012-6135: RubyGems passenger gem allows remote attackers to delete files

> Remote attackers can delete arbitrary files during the startup process of the Ruby application server.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Nov 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-8mw8-j583-vqfg

## What is CVE-2012-6135?

CVE-2012-6135 is a high-severity path traversal vulnerability in Redhat Openshift, published on 19 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RubyGems passenger 4.0.0 betas 1 and 2 allows remote attackers to delete arbitrary files during the startup process.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2012-6135?

2 open source packages ship an affected version, including passenger. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `passenger` | RubyGems | All versions | 4.0.0.rc4 |
| `passenger` | RubyGems | All versions | 4.0.0.rc4 |

Products: Phusion Passenger, Redhat Openshift.

## How do I fix CVE-2012-6135?

Upgrade passenger to 4.0.0.rc4 or later.

## Is CVE-2012-6135 being exploited?

There is no known exploitation of CVE-2012-6135 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Openshift

- [CVE-2018-12026](https://insights.sbomify.com/CVE-2018-12026/): Phusion Passenger SpawningKit Contains Arbitrary Read/Write Vulnerability (critical 9.8)
- [CVE-2018-12027](https://insights.sbomify.com/CVE-2018-12027/): Insecure Permissions in Phusion Passenger (high 8.8)
- [CVE-2018-12028](https://insights.sbomify.com/CVE-2018-12028/): Incorrect Access Control in Phusion Passenger (high 7.8)
- [CVE-2016-10345](https://insights.sbomify.com/CVE-2016-10345/): Phusion Passenger uses a known /tmp filename (high 7.8)
- [CVE-2025-26803](https://insights.sbomify.com/CVE-2025-26803/): Phusion Passenger denial of service (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2012-6135 and fix it if it is affected.

What it is: CVE-2012-6135 is a high-severity path traversal vulnerability in Redhat Openshift, published on 19 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2012-6135 in the wild and no public exploit code.

Affected packages and fixed versions:
- passenger (RubyGems): affected all versions; fixed in 4.0.0.rc4
- passenger (RubyGems): affected all versions; fixed in 4.0.0.rc4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2012-6135/ (Markdown: https://insights.sbomify.com/CVE-2012-6135/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2012-6135
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2012-6135
- OSV: https://osv.dev/vulnerability/CVE-2012-6135

---
From sbomify Insights: https://insights.sbomify.com/CVE-2012-6135/
Summaries are generated and may contain mistakes; the official description above is the record.
