CVE-2012-6147 Typo3 Backend API XSS Vulnerability

Low 3.5 Published Updated

Authenticated backend users can inject arbitrary scripts via the TCA-Tree API, potentially compromising other users' sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2012-6147?

CVE-2012-6147 is a low-severity cross-site scripting vulnerability in Typo3 Typo3, published on 1 Jul 2013. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in the tree render API (TCA-Tree) in the Backend API in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 allows remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79

Which versions are affected by CVE-2012-6147?

6 open source packages ship an affected version, including typo3/cms. It affects 1 product.

PackageAffectedFixed in
typo3/cms PackagistFrom 4.5.04.5.21
typo3/cms PackagistFrom 4.5.04.5.21
typo3/cms PackagistFrom 4.6.04.6.14
typo3/cms PackagistFrom 4.6.04.6.14
typo3/cms PackagistFrom 4.7.04.7.6
typo3/cms PackagistFrom 4.7.04.7.6

Products include Typo3 Typo3.

How do I fix CVE-2012-6147?

Upgrade typo3/cms to a fixed version for your release line: 4.5.21, 4.6.14 or 4.7.6.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2012-6147 being exploited?

There is no known exploitation of CVE-2012-6147 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as GHSA-qmmw-ch2q-j6xx.

Is CVE-2012-6147 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free